Ie redirection [Résolu]

nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 28 nov. 2017 à 12:17 - Dernière réponse : nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention
- 29 nov. 2017 à 10:49
salut à tous,


Bon je tournes complètement en rond pour une redirection javascript sous ie, rien ne fonctionne .. J'ai tenté :
    window.location.href = url;
    window.location = url;
    location.replace(url);
    window.location.replace(url);


ainsi que
  var red = document.createElement("div");
  red.id = 'ynicwf587';
  var HTMLvalue = "<a href='" + url + "'>url</a>";
  red.innerHTML =HTMLvalue;
  document.body.insertBefore(red, document.body.childNodes[0]); 
  document.getElementById(red.id).click();


mais rien ne marche ... pas d erreurs, pas de warning, rien de rien ...

je ne sais plus trop quoi faire, le js est bien actif sous ie (11) bref si quelqu'un a une idée je prends, là je sais plus x)

merci d'avance!

naga
Afficher la suite 
4147Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention

7 réponses

Répondre au sujet
jordane45 19201 Messages postés mercredi 22 octobre 2003Date d'inscriptionModérateurStatut 10 décembre 2017 Dernière intervention - 28 nov. 2017 à 12:19
0
Utile
6
Bonjour,

La première question est :
où as tu placé ton code ?

Ensuite..; comment y fais tu appel ? Un bouton ? Automatiquement ? via l'appel d'une fonction ??


Pour pouvoir t'aider il nous faut le code COMPLET.
jordane45 19201 Messages postés mercredi 22 octobre 2003Date d'inscriptionModérateurStatut 10 décembre 2017 Dernière intervention > nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 28 nov. 2017 à 14:14
<html>
<head>
<title>TEST</title>
</head>
<body>
<script type="text/javascript">
var url='http://www.google.fr';
    document.location = url;  
</script>
</body>
</html>
nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 28 nov. 2017 à 14:30
c'est en effet un des tests que j'ai fait et qui ne fonctionne pas.

Entre temps j'ai aussi essayé d’insérer un formulaire et faire le submit => pareil

Le truc c'est que rien ne soulève d'erreurs ou autre, ca interprete bien mais ne fais strictement rien ...

Pour le moment j'ai juste mis un lien cliquable si je suis sous ie ou ff (oui il y a le même problème sous ff mais je m y suis beaucoup moins penché vu que de toutes facons c'est pas utilisé dans mon contexte ou tellement peu) ... bref tout marche sous chrome, ce qui est bien vu que c'est un navigateur qui n'est pas utilisé à mon taff --- bref x)

merci quand même
jordane45 19201 Messages postés mercredi 22 octobre 2003Date d'inscriptionModérateurStatut 10 décembre 2017 Dernière intervention > nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 28 nov. 2017 à 15:16
Aucun souci avec ce code.... ni avec IE ni avec chrome ni avec FF ...

Et vu les symptômes que tu décris.... ce n'est clairement pas un souci de code...

Es-tu sûr que tes fichiers ne seraient pas avec un encodage à la noix ???
Assures toi qu'ils sont en utf8 sans bom
nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 28 nov. 2017 à 16:46
Nan, mais y a peut être une règle que j ai pas vu d appliqué dans ma boîte, j ai déjà regardé mais dans le doute... je redirai ça demain et je clôturerai le sujet avec une solution (ou pas x) )
nagaD.scar 4147 Messages postés samedi 8 septembre 2007Date d'inscription 6 décembre 2017 Dernière intervention - 29 nov. 2017 à 10:49
bon bah voilà, règle de ****** du coup pas de redirection auto, tant pis ^^

merci
Commenter la réponse de jordane45