Formule Excel si cellule contient un texte... [Résolu]

JuJu63000 4 Messages postés mardi 28 novembre 2017Date d'inscription 28 novembre 2017 Dernière intervention - 28 nov. 2017 à 10:32 - Dernière réponse : JuJu63000 4 Messages postés mardi 28 novembre 2017Date d'inscription 28 novembre 2017 Dernière intervention
- 28 nov. 2017 à 13:56
Bonjour,

Voila mon problème:

dans un tableau excel j'ai une colonne B qui contient une liste déroulante de choix (la liste et dans une autre feuille, c'est le choix du type de luminaire, par exemple: Spots encastrés), dans la cellule C je veux mettre la traduction de la cellule B ( par exemple: Recessed spots, qui est situé dans dans une autre feuille).

En gros, il faut que si la colonne B = X (X étant le type de luminaire) alors dans la colonne C j'ai la valeur Y ( Y qui correspond à la colonne de droite de X).






Je vous remercie beaucoup d'avance de votre aide.
Afficher la suite 

7 réponses

Répondre au sujet
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 28 nov. 2017 à 10:38
0
Utile
1
Bonjour,
un exemple de ton fichier Excel serait mieux que long discours et capture écran
anonymise ton fichier ou crée un exemple et joint le à la discussion
1) Clic sur ce http://cjoint.com/
2) Clic sur Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien
4) Un lien en bleu souligné sera généré en haut de page, sélectionne clic droit "Copier"
5) reste plus qu'a le "Coller" dans une réponse avec quelques explications.
JuJu63000 4 Messages postés mardi 28 novembre 2017Date d'inscription 28 novembre 2017 Dernière intervention - 28 nov. 2017 à 10:43
Merci pour ton aide, je ne trouver pas comment le faire :)

Voici le lien de l'exemple:

http://www.cjoint.com/c/GKCjOq1aH16

Si tu à des questions en particulière dis le moi, je pense avoir tout dis dans mon explication.
Commenter la réponse de Mike-31
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 28 nov. 2017 à 10:54
0
Utile
1
Re,

en cellule C5 colle cette formule
=RECHERCHEV(B4;'traductions tableau pdt'!$B$2:$C$27;2;0)

maintenant tu peux l’améliorer, onglet "traductions tableau pdt" ton tableau tu peux le nommer exemple la plage B2:C27 tu la nommes Tablo
la formule devient
=RECHERCHEV(B4;Tablo;2;0)

si tu ne sais pas comment nommer ta plage reviens sur la discussion
JuJu63000 4 Messages postés mardi 28 novembre 2017Date d'inscription 28 novembre 2017 Dernière intervention - 28 nov. 2017 à 11:20
Merci, ça marche super bien ! et l'idée de la plage est pas mal pour éviter les formules à rallonge :)

J'aurai une autre question pour améliorer la formule, je voudrais qu'on ne puisse pas fais d'erreur, la si on copie et colle la formule que tu m'a donné( =RECHERCHEV(B4;Tablo;2;0) ) en C5 par exemple cela décale tout, il faudrait remplacer le "B4" par exemple par la colonne B je pense. dis moi si c'est possible ? et encore merci !
Commenter la réponse de Mike-31
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 28 nov. 2017 à 12:21
0
Utile
2
Re,

B4 par la colonne B non, mais tu peux incrémenter la formule sur la hauteur que tu veux, de B4 tu la tire vers le bas
Vaucluse 20847 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 28 nov. 2017 à 12:41
Bonjour
(et salut Mike)
et pour copier la formule en C5 en conservant le, B
écrivez d'abord:
=RECHERCHEV($BA;Tablo;0)
qui conservera le B et passera le 4 en 5
le $ devant la colonne bloque la colonne, devant la ligne bloque la ligne et devant tout bloque tout
crdlmnt
JuJu63000 4 Messages postés mardi 28 novembre 2017Date d'inscription 28 novembre 2017 Dernière intervention > Vaucluse 20847 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 28 nov. 2017 à 13:56
Merci c'est exactement ce que je voulais !
Commenter la réponse de Mike-31