Aide pour formule [Résolu]

Aztek33 577 Messages postés lundi 7 mai 2007Date d'inscription 25 novembre 2017 Dernière intervention - 25 nov. 2017 à 11:01 - Dernière réponse : Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 25 nov. 2017 à 14:34
Bonjour,

J'aurai besoin de votre aide pour placer des appréciations dans une cellule.
B10 est un score en percentile sur une courbe de Gauss.

La voici :
=SI(B10>=0;SI(B10<=2;"déficitaire";SI(B10<=16;"faible";SI(B10<=84;"normal";SI(B10<=98;"élevé")))))

Sur certain scores p. ex. lorsque pc= 59 j'ai un "FAUX" sur cette cellule.

Où est mon erreur ?

Merci d'avance !
Afficher la suite 
577Messages postés lundi 7 mai 2007Date d'inscription 25 novembre 2017 Dernière intervention

5 réponses

Répondre au sujet
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Vaucluse le 25/11/2017 à 11:38
+1
Utile
Bonjour

correction sur la 1° pour être tranquille selon ce que vous avez en B10:

=SI(OU(B10=0;B10="");"";SI(B10<=2;"déficitaire";SI(B10<=16;"faible";SI(B10<=84;"normal";SI(B10<=98;"élevé")))))

ça devrait aller... ou alors c'est qu'il y a des erreurs dans la valeur de B10 (% texte.. etc?)

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
Aztek33 577 Messages postés lundi 7 mai 2007Date d'inscription 25 novembre 2017 Dernière intervention - 25 nov. 2017 à 12:53
0
Utile
1
Merci Vaucluse pour votre réponse, cela fonctionne.

J'ai toutefois voulu préciser un peu mes valeurs et là, cela ne fonctionne plus quand le pc = 99. Je ne vois pas mon erreur. Voici la formule :

=SI(OU(B10=0;B10="");"";SI(B10<=2;"Effet déficitaire";SI(B10<=16;"Apprentissage compliqué";SI(B10<=27;"Apprentissage subnormal";SI(B10<=84;"Effet normal";SI(B10<=95;"Effet élevé";SI(B10<=99;"Effet très élevé")))))))

Merci de votre aide !
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 25 nov. 2017 à 13:00
Re

... moi non plus je ne vois pas, sauf si le pc résulte d'un calcul qui donne des décimales au delà de 99 et qui ne s'affichent pas dans votre format de cellule?

à vérifier, essayez avec 99,99
Mais si vous n'avez pas de limite de valeur à traiter au delà de 95, il suffit de terminer votre formule par:

.......SI(B10<=95;"Effet élevé";"Effet très élevé"))))))

(avec une parenthèse de moins)

qui vous donnera "Effet très élevé" pour tout ce qui dépasse 95

crdlmnt
Commenter la réponse de Aztek33
Aztek33 577 Messages postés lundi 7 mai 2007Date d'inscription 25 novembre 2017 Dernière intervention - 25 nov. 2017 à 14:30
0
Utile
1
Avec votre nouvelle formule, cela résous mon problème !

Merci de votre aide !
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 25 nov. 2017 à 14:34
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Aztek33