Signaler

Image de fond qui s'affiche avec adresse longue mais pas courte [Résolu]

Posez votre question utahime1 88Messages postés jeudi 31 mai 2007Date d'inscription 14 novembre 2017 Dernière intervention - Dernière réponse le 14 nov. 2017 à 13:22 par utahime1
Bonjour,

Je cherche à mettre une image de fond qui ne s'affiche sur aucun navigateur à moins d'y mettre l'"adresse longue".

Je suis en local. L'arborescence de mon dossier :

mon fichier html >> images >> fond-site.jpg
>> css >> style.css
>> font >> theblacklist-webfont.woff
>> theblacklist-webfont.woff2

Si j'entre "background-image: url(images/fond-site.jpg);" ce que j'appelle url "courte", on ne voit l'image nulle part.
J'ai tenté avec ou sans guillemets en ajoutant avant ../images etc...

Seul l'adresse "longue" file:///C:/Users/Utahi/Documents/RECHERCHE%20EMPLOI/FORMATIONS/Open%20classrooms/cr%C3%A9er%20site%20web/exercice%20cv%20css/images/fond-site.jpg" fonctionne. Le problème c'est que je dois envoyer mon dossier qui ne fonctionne pas dans d'autres pc puisque l'adresse changera.

body
{
 background-image: url("file:///C:/Users/Utahi/Documents/RECHERCHE%20EMPLOI/FORMATIONS/Open%20classrooms/cr%C3%A9er%20site%20web/exercice%20cv%20css/images/fond-site.jpg");
 }



Tout le reste fonctionne dès que je modifie quoique ce soit dons as de soucis dans les cookies. (sauf pour les polices mais je créerais un autre sujet)
Utile
+0
plus moins
Merci pour vos réponses.

(désolé, j'ai valider avant de finir d'écrire mon message, je fais mal polie :P)
Donnez votre avis
Utile
+0
plus moins
Problème résolu. J'avais bien tout bon dans ma fonction, j'ai juste changer de pc.

un paramétrage certainement bloque mais je n'ai pas le temps de voir.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !