Signaler

Dernière valeur non nulle

Posez votre question fifimilla - Dernière réponse le 15 nov. 2017 à 12:22 par eriiic
Bonjour,

j'ai un problème avec les formules excel ,je souhaite déterminer le nombre de jours ou la vente est nulle aprés la dernière vente je joins mon fichier exemple.
merci d'avance.
http://www.cjoint.com/c/GKno4W3BKzD
Utile
+0
plus moins
Bonjour,

une fonction perso:
http://www.cjoint.com/c/GKnpWjb35jf
fifimilla- 14 nov. 2017 à 11:41
merci beaucoup le problème est réglé
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

par formule :
=COLONNES(B2:W2)-MAX((B2:W2>0)*COLONNE(B2:W2))+1 

formule matricielle à valider avec shift+ctrl+entrée
La formule doit s'entourer de { } si la validation est correcte.
eric
Donnez votre avis
Utile
+0
plus moins
merci la formule fonctionne mais dans le cas ou le commercial ne vend pas au cours des 22 jours le résultat est 23
je comprend pas ou est le problème,mais j'ai testé la solution de f894009 qui fonctionne parfaitement
merci encore une fois
eriiic 21173Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 15 novembre 2017 Dernière intervention - 14 nov. 2017 à 16:25
??????
Répondre
fiffimilla- 15 nov. 2017 à 08:41
=SI(SOMME(B2:W2);COLONNES(B2:W2)-MAX((B2:W2>0)*COLONNE(B2:W2))+1;colonnes(B2:W2))
Répondre
eriiic 21173Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 15 novembre 2017 Dernière intervention - 15 nov. 2017 à 09:42
Bonjour,
C'est bien ce que j'avais compris.
Mais comme dans ton exemple tu voulais 0 dans ce cas...
Répondre
fiffimilla- 15 nov. 2017 à 11:05
non je voulais 22 jours (nombre de jours ou le commercial n'a rien vendu)
merci encore une fois Eriiic pour ton aide
Répondre
eriiic 21173Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 15 novembre 2017 Dernière intervention - 15 nov. 2017 à 12:22
J'avais pris le fichier de f894009 comme base pour comparer les résultats, qui retournait 0.
Je comprend mieux la confusion que j'ai faite :-)
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !