Signaler

Multiplier 2 colonnes sur excel [Résolu]

Posez votre question Marie - Dernière réponse le 10 nov. 2017 à 09:58 par Marie
Bonjour,

je cherche à multiplier A1 par D1 puis A2 par D2 etc jusqu'à A40 par D40 et à obtenir le résultat dans une seule cellule sans recréer une colonne supplémentaire.
Une astuce?
grand merci,
Marie


Utile
+0
plus moins
Bonsoir
Si c'est (A1*D1)+A2*D2)+(A...*D...)
Alors
=SOMMEPROD(A1:A40;D1:D40)
Donnez votre avis
Utile
+0
plus moins
Bonjour

=SOMMEPROD((A1:A40)*(D1:D40))

Cdlmnt
Via
Donnez votre avis
Utile
+0
plus moins
Bonjour amical à yclik et à Via.
Bonjour à toi, Marie.

Ce n'est pas une astuce qui t'a été fournie, mais deux formules, utilisant chacune la fonction SOMMEPROD ...

Elles donnent évidemment le même résultat, à une différence près :
si tu saisis accidentellement un texte à la place d'une valeur numérique,
avec la syntaxe d'yclik =SOMMEPROD(A1:A40;D1:D40) Excel considérera qu'il y a la valeur zéro dans la cellule ;
avec la syntaxe de Via =SOMMEPROD((A1:A40)*(D1:D40)) Excel signalera l'erreur en affichant comme résultat
#VALEUR!


Cordialement.
Donnez votre avis
Utile
+0
plus moins
Bonjour chers aideurs!
Je vous remercie de vos réponses!
Cela fonctionne!
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !