Multiplier 2 colonnes sur excel [Résolu]

Marie - 9 nov. 2017 à 16:57 - Dernière réponse :  Marie
- 10 nov. 2017 à 09:58
Bonjour,

je cherche à multiplier A1 par D1 puis A2 par D2 etc jusqu'à A40 par D40 et à obtenir le résultat dans une seule cellule sans recréer une colonne supplémentaire.
Une astuce?
grand merci,
Marie


Afficher la suite 

4 réponses

Répondre au sujet
yclik 1233 Messages postés vendredi 25 juillet 2014Date d'inscription 14 février 2018 Dernière intervention - 9 nov. 2017 à 17:01
0
Utile
Bonsoir
Si c'est (A1*D1)+A2*D2)+(A...*D...)
Alors
=SOMMEPROD(A1:A40;D1:D40)
Commenter la réponse de yclik
via55 9043 Messages postés mercredi 16 janvier 2013Date d'inscription 14 février 2018 Dernière intervention - 9 nov. 2017 à 17:03
0
Utile
Bonjour

=SOMMEPROD((A1:A40)*(D1:D40))

Cdlmnt
Via
Commenter la réponse de via55
Raymond PENTIER 45091 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 14 février 2018 Dernière intervention - 10 nov. 2017 à 01:43
0
Utile
Bonjour amical à yclik et à Via.
Bonjour à toi, Marie.

Ce n'est pas une astuce qui t'a été fournie, mais deux formules, utilisant chacune la fonction SOMMEPROD ...

Elles donnent évidemment le même résultat, à une différence près :
si tu saisis accidentellement un texte à la place d'une valeur numérique,
avec la syntaxe d'yclik =SOMMEPROD(A1:A40;D1:D40) Excel considérera qu'il y a la valeur zéro dans la cellule ;
avec la syntaxe de Via =SOMMEPROD((A1:A40)*(D1:D40)) Excel signalera l'erreur en affichant comme résultat
#VALEUR!


Cordialement.
Commenter la réponse de Raymond PENTIER
0
Utile
Bonjour chers aideurs!
Je vous remercie de vos réponses!
Cela fonctionne!
Commenter la réponse de Marie