Signaler

Formule pour calculer une immobilisation [Résolu]

Posez votre question RAF26ML 22Messages postés mardi 22 août 2017Date d'inscription 14 novembre 2017 Dernière intervention - Dernière réponse le 14 nov. 2017 à 14:38 par Mike-31
Bonjour,

j'ai repris un fichier excel pour calculer la dotation d'une immobilisation,
sauf qu'il n'y a aucune formule et j'ai un peu de mal à la formuler ?

Pouvez-vous m'aider ?, j'essaye de joindre le fichier est en pièce jointe

par avance merci.


Utile
+0
plus moins
Bonsoir,

Pour joindre ton fichier anonymisé
1) Clic sur ce http://cjoint.com/
2) Clic sur Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien
4) Un lien en bleu souligné sera généré en haut de page, sélectionne clic droit "Copier"
5) reste plus qu'a le "Coller" dans une réponse avec quelques explications.
Donnez votre avis
Utile
+0
plus moins
Re,
Reste sur la discussion et n'ouvre pas des discussions en doublon

j'ai transféré ci dessous le lien de ton fichier avant que ta discussion en doublon ne soit fermé par la modération

http://www.cjoint.com/c/GKhtreLsVk4

tu peux mettre les valeurs du résultat attendu dans tes colonnes s'il te plait et nous retourner le fichier afin d'adapter les formules

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Donnez votre avis
Utile
+0
plus moins
Merci pour le doublon.....


http://www.cjoint.com/c/GKhu4tF2F64
Donnez votre avis
Utile
+0
plus moins
en cellule N4 colle cette formule que tu incrémentes vers le bas puis vers la droite
=SI(OU(INDIRECT("A"&LIGNE())="";ANNEE($C4)+$E4<INDIRECT(CAR(COLONNE()+64)&1));"";SI(ANNEE($C4)+$E4=INDIRECT(CAR(COLONNE()+64)&1);$B4-SOMME($M4:INDIRECT(ADRESSE(LIGNE();COLONNE()-1;4)));INDIRECT("B"&LIGNE())/INDIRECT("E"&LIGNE()))) 


vu la complexité de la formule afin qu'elle s'adapte aussi bien aux colonnes qu'aux ligne je te conseille de la protéger soit en protégeant ta feuille

peux tu m'éclairer sur tes formule colonne M ou tu multiplie par 31 ou 204 ou 174 ou encore 121
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Tout d'abord merci beaucoup pour la formule, elle convient parfaitement,
pour la colonne M, le 31 correspond à 31 jours du 30 novembre date d'acquisition du matériel au 30 décembre. C'est le plus difficile pour moi à paramétrer, il faut partir de la date d'acquisition du matériel jusqu'au 30 décembre sur une année de 360 jours.....

encore merci...
Donnez votre avis
Utile
+0
plus moins
Re,

toi tu trouves
31
204
174
121

alors que d'après tes explications je trouve
30
206
166
122

quel mode de calcul utilises tu pour arriver logiquement à tes résultats

Donnez votre avis
Utile
+0
plus moins
En fait, l'année comporte 12 mois de 30 jours soit 360 jours, pour le premier cas, il faut aussi compter le 30 novembre et ensuite 30 jours pour décembre donc 31,

Cdt
Donnez votre avis
Utile
+0
plus moins
Après vérif, effectivement :
c'est bien 204 jours du 7 au 30 juin 24j+ 6 mois *30j=180+24=204

par contre c'est 164 j du 17 au 30 juillet =14j + 5 mois * 30j = 150+14= 164

dernier 121

j'espère être un peu plus claire...

Cdt
Donnez votre avis
Utile
+0
plus moins
Ok vu, mais en M6 tu trouves 174 en es tu sur parce que je trouve 164

du 17/07/2017 au 30/07/2017 13 jours +1 soit 14
ensuite 5 mois jusqu'en décembre * 30 =150
ce qui donne 164 et non 174
pour les autres c'est bon j'ai la formule
Donnez votre avis
Utile
+0
plus moins
OUI 164, je l'ai recalculé plus haut...

merci
Donnez votre avis
Utile
+0
plus moins
Re,

alors en M4 colle cette formule et incrémente vers le bas

=SI(A4="";"";B4/E4/$E$2*(SOMME(30-JOUR(C4)+(12-MOIS(C4))*30)+1)) 

Donnez votre avis
Utile
+0
plus moins
Super !!! Merci beaucoup pour votre aide....

Bonne soirée.
Donnez votre avis
Utile
+0
plus moins
Oups ! petit soucis, j'ai voulu adapter la formule à un autre tableau d'immo
elle fonctionne jusqu'à la colonne Z ensuite il me met "REF" quand j'incrémente la colonne AA ?

=SI(OU(INDIRECT("A"&LIGNE())="";ANNEE($C4)+$E4<INDIRECT(CAR(COLONNE()+64)&1));"";SI(ANNEE($C4)+$E4=INDIRECT(CAR(COLONNE()+64)&1);$B4-SOMME($M4:INDIRECT(ADRESSE(LIGNE();COLONNE()-1;4)));INDIRECT("B"&LIGNE())/INDIRECT("E"&LIGNE())))

Désolée Mike 31 ...
Donnez votre avis
Utile
+0
plus moins
Re,

pour gérer les index colonnes à deux chiffres il faut compléter la formule comme cela mais il va falloir arrêter la parce que l'on va arriver aux limites des possibilités des conditions
en N4 colle cette formule et incrémente la vers le bas et vers la droite

=SI(OU(INDIRECT("A"&LIGNE())="";INDIRECT(ADRESSE(1;COLONNE()))="";ANNEE($C4)+$E4<INDIRECT(SI(COLONNE()<=26;CAR(COLONNE()+64);CAR(ENT((COLONNE()-1)/26)+64)&CAR(COLONNE()-(26*ENT((COLONNE()-1)/26))+64))&1));"";SI(ANNEE($C4)+$E4=INDIRECT(SI(COLONNE()<=26;CAR(COLONNE()+64);CAR(ENT((COLONNE()-1)/26)+64)&CAR(COLONNE()-(26*ENT((COLONNE()-1)/26))+64))&1);$B4-SOMME($M4:INDIRECT(ADRESSE(LIGNE();COLONNE()-1;4)));INDIRECT("B"&LIGNE())/INDIRECT("E"&LIGNE())))

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Donnez votre avis
Utile
+0
plus moins
Re,

Es ce que la formule est bonne !
Donnez votre avis
Utile
+0
plus moins
Bonjour,

apparemment non, mais peut-être que je ne l'adapte pas comme il faut.

En pièce jointe le tableau en entier.

Merci.

http://www.cjoint.com/c/GKkhuGWpQns
Donnez votre avis
Utile
+0
plus moins
Re,

c'est normal tu n'as pas adapté ma dernière formule, en W44 colle cette formule (attention de ne pas coller un espace en fin

=SI(OU(INDIRECT("A"&LIGNE())="";INDIRECT(ADRESSE(1;COLONNE()))="";ANNEE($D44)+$F44<INDIRECT(SI(COLONNE()<=26;CAR(COLONNE()+64);CAR(ENT((COLONNE()-1)/26)+64)&CAR(COLONNE()-(26*ENT((COLONNE()-1)/26))+64))&1));"";SI(ANNEE($D44)+$F44=INDIRECT(SI(COLONNE()<=26;CAR(COLONNE()+64);CAR(ENT((COLONNE()-1)/26)+64)&CAR(COLONNE()-(26*ENT((COLONNE()-1)/26))+64))&1);$B44-SOMME($V44:INDIRECT(ADRESSE(LIGNE();COLONNE()-1;4)));INDIRECT("B"&LIGNE())/INDIRECT("F"&LIGNE())))


je regarde si je peux ajouter des conditionnelles pour calculer dans la même formule le premier versement et n'avoir qu'une seule formule
Donnez votre avis
Utile
+0
plus moins
Bonjour,

la formule ne marche pas, je copie et colle, je vois bien la formule dans la cellule par contre celle-ci reste vide....

http://www.cjoint.com/c/GKoi458hLXs

peut-être est-elle trop longue...

Merci
Donnez votre avis
Utile
+0
plus moins
Re,

je n'ai fait que coller la formule en W26 et incrémenté vers la droite et en W44 incrémenté vers le bas et la droite
http://www.cjoint.com/c/GKojigOua5j
Donnez votre avis
Utile
+0
plus moins
super ça marche ! c'est de ma faute, j'essayais de la coller en AA26.

la formule est super complexe, je ne sais pas si j'arriverai à la conserver dans le temps... la 1ère oui mais la 2ème... dans tous les cas merci beaucoup
pour l'instant tout marche.

bonne journée.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !