Signaler

Compiler sous visual studio code [Résolu]

Posez votre question Fallentree 1897Messages postés mercredi 25 février 2009Date d'inscription 5 novembre 2017 Dernière intervention - Dernière réponse le 5 nov. 2017 à 10:55 par Fallentree
Bonjour,
Apres avoir installer Visual Studio Code et installer MinGW, impossible de compiler...
Essayons de tout reprendre dans l'ordre...
En suivant ces instructions, création de fichiers de configuration suivant:
- code completion : c_cpp_properties.json => avec le Path de MinGW
- build :tasks.json => command g++
- Debugging : launch.json => miDebuggerPath

Et puis "Tasks: Run Build Task (Ctrl+Shift+B)"
g++ : Le terme «g++» n'est pas reconnu comme nom d'applet de commande, fonction, fichier de script ou programme exécutable. Vérifiez l'orthographe du nom, ou si un chemin d'accès existe, vérifiez que le chemin d'accès est correct
et réessayez.
Au caractère Ligne:1 : 1
+ g++ -g helloworld.cpp
+ ~~~
+ CategoryInfo : ObjectNotFound: (g++:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException


Visiblement un problème pourtant les Paths semble correct...
Merci de votre lecture.
Utile
+1
plus moins
Modification du Path des variables d' environnement de Cmd.exe

Panneau de configuration\Tous les Panneaux de configuration\systeme \variables d environemment

C'est ça...........

Commande du g++ reconnue.

ajout du path suffisant .
Donnez votre avis
Utile
+0
plus moins
Dans MinGW Installation Manager, mingw32-gcc-g++ est bien installé
Fallentree 1897Messages postés mercredi 25 février 2009Date d'inscription 5 novembre 2017 Dernière intervention - 4 nov. 2017 à 15:09
figurez vous que une dépendance de iostream : "bits/c++config.h" , n'est pas présente...
Répondre
Fallentree 1897Messages postés mercredi 25 février 2009Date d'inscription 5 novembre 2017 Dernière intervention - 4 nov. 2017 à 18:57
c_cpp_properties.json
"includePath": [
"${workspaceRoot}",
"e:/MinGW/lib/gcc/mingw32/6.3.0/include/c++",
"e:/MinGW/lib/gcc/mingw32/6.3.0/include",
"e:/MinGW/lib/gcc/mingw32/6.3.0/include/c++/mingw32",
"e:/MinGW/lib/gcc/mingw32/6.3.0/include/c++/tr1",
"e:/MinGW/include/"
],

déjà un probleme de moins
Plus qu'à trouver comment faire pour qu il reconnaisse g++ comme commande ..
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,
Où se trouve le Path du compilateur?
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !