Publipostage word avec excel et images

PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 24 oct. 2017 à 18:41 - Dernière réponse :  MarieNova
- 31 janv. 2018 à 17:52
Bonjour,
Après avoir parcouru les forums sur ce sujet, je tente désespérément de réaliser un publipostage avec word 2016 (attestation candidat) et un fichier source excel qui comporte les coordonnées et la photo de chaque candidat
La photo n'apparaît pas lors de la fusion malgré les conseils trouvés sur ces forums.
Merci par avance de votre aide
Bien cordialement
Huguette


Afficher la suite 

14 réponses

Répondre au sujet
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention - 25 oct. 2017 à 12:09
0
Utile
8
Bonjour

On ne connaît pas la méthode que tu as utilisée jusqu'ici
Suis d'abord ce tuto de la faqword ici :
http://faqword.com/index.php/word/tutos/toutes-versions/93-publimage
et reviens si souci en indiquant où tu coinces
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention > PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 29 oct. 2017 à 14:09
Bonjour

Sur le document fusionné, fais Alt+F9 pour afficher les codes champs et dis-moi ce que tu trouves

Argitxu
PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention > Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention - 29 oct. 2017 à 14:58
Je n'ai rien qui s'affiche : aucun champ
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention > PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 29 oct. 2017 à 16:51
C’est bien ça. Le document fusionné doit afficher plusieurs champs INCLUDEPICTURE avec les noms de chacune des images ainsi, tel que dans le champ ‘photo’ du fichier excel :
{ INCLUDEPICTURE "C:\\.....le chemin indiqué dans le champ “photo” du fichier excel…..\\nomdel’image.jpg " }

Regarde d’abord dans les options word, rubrique ‘affichage du contenu des documents’ : ‘Afficher les espaces pour images’ doit être désactivé

Si non, il y a un problème de montage en amont aux étapes 1 et 2.

Argitxu
PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention > Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention - 29 oct. 2017 à 17:51
Mon option est bien décochée, j'ai tout refait, toujours le même problème
Grrr !!!
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention > PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 29 oct. 2017 à 18:50
Peux-tu déposer un petit bout du fichier excel retraité avec 1 ou 2 lignes en anonymisant tout ce qui peut l'être, mais en gardant le champ photo tel qu'il est défini pour ta fusion et le fichier word retraité en ne gardant que le champ
Utilise http://www.cjoint.com/
Charge chaque fichier, crée un lien, copie-le et colle-le ici

Argitxu
Commenter la réponse de Argitxu
PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 29 oct. 2017 à 20:02
0
Utile
1
Fichier source :
http://www.cjoint.com/c/GJDs7px5ZpR
Document type :
http://www.cjoint.com/c/GJDtaSwCLmR

Merci pour ton aide

Huguette
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention - 29 oct. 2017 à 21:07
Tu n’as pas bien vérifié...

Sur le fichier source excel, champ ‘Photos’, il manque des doubles antislashs. Ils sont indispensables
Il faut E:\\ATTESTATIONS\\DOSSIER IMAGE\\BAKACH Oan.jpg

Un détail important : le nom des images ne doivent pas avoir des espaces. Si tu ne peux pas les éviter, remplace les par des underscores (tiret du 8)

Sur le fichier word, tu as inséré 3 champs Ctrl+F9)
Il faut { INCLUDEPICTURE "{ MERGEFIELD Photos }" \d }
En pratique, fais un Ctrl+F9 : à l’intérieur des accolades, saisis INCLUDEPICTURE, ouvrir un guillemet, puis Ctrl+F9 pour entrer le MERGEFIELD Photos, tu fermes avec le guillemet et le \d pour lier les photos



Argitxu
Commenter la réponse de PseudoHL
PseudoHL 7 Messages postés mardi 24 octobre 2017Date d'inscription 29 octobre 2017 Dernière intervention - 29 oct. 2017 à 21:26
0
Utile
1
Merci pour ton aide
J'ai rajouté des undescores dans les noms des fichiers (dossier image) et dans le chemin (fichier excel) et je n'aboutis pas
J'ai aussi bien vérifié avoir mis les doubles antislashs dans la colonne Photos (fichier excel)
Voici la procédure et les captures d'écran pour plus de précisions
http://www.cjoint.com/c/GJDuwYJqnJR
D'autres options word qui pourraient gêner ?
Je ne pourrais pas trouver sur le net un fichier excel et un document word qui correspondrait à mon cas ?
Merci encore
Huguette
Argitxu 4761 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 11 février 2018 Dernière intervention - 29 oct. 2017 à 22:48
Ce que je vois sur ton fichier où tu récapitules ton organisation :
1. Ne travaille pas sur un disque amovible, mais stocke tous tes fichiers sur ton disque dur
2. Contrairement à ce que tu mets ci-dessus, les noms des images sont avec espace qu'il faut remplacer par un underscore
3. Le chemin que tu mets dans le fichier excel doit bien être
E:\\ATTESTATIONS\\2CAP\\BAKACH_Oan.jpg
et enfin
4. le champ dans word : { INCLUDEPICTURE "{ MERGEFIELD Photos }" \d }
Tu as doublé le Ctrl+F9

http://www.cjoint.com/c/GJDvVFdHT2J

Argitxu
Commenter la réponse de PseudoHL
0
Utile
Bonjour,
J'ai le même problème que pseudoHL :
sous word 2016, lorsque je fusionne le champ {INCLUDEPICTURE "{MERGEFIELD logo}"}, le champ disparaît.
J'ai vérifié les les différents points évoqués ci-dessus :
- pas d'espace dans les noms d'image
- j'ai copié collé l'adresse des liens vers l'image qui fonctionne sous excel. Il y a bien les doubles anti-slash.
- j'ai bien utilisé deux fois ctrl+Fn+F9 (ctrl + F9 ne fontionne apparemment pas sur mon pc) pour taper la formule. Je l'ai d'ailleurs essayée avec et sans les guillemets, en insérant ou en tapant le mot logo...
Rien n'y fait, le champ disparaît.
Auriez-vous une solution pour résoudre le problème ?
Par avance, merci !
Marie
Commenter la réponse de MarieNova