Fonction rechercheV dans deux feuilles et deux colonnes

edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 20 oct. 2017 à 11:17 - Dernière réponse : edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention
- 10 nov. 2017 à 13:57
Hello tout le monde !

J'ai besoin de votre aide pour une question à propos de la fonction rechercheV, merci d'avance.
Mon objectif est de comparer 2 colonnes de deux feuilles différentes. Les colonnes A et N de chaque feuille pour vérifier s'il n'y a pas eu de nouvelles valeurs arrivées entre mes deux excel. J'ai besoin de deux colonnes car certaines valeurs se retrouvent plusieurs fois dans la colonne A et la colonne N permet de rendre chaque ligne (combinaison) "unique".

Merci pour votre temps !
Afficher la suite 

7 réponses

Répondre au sujet
via55 8939 Messages postés mercredi 16 janvier 2013Date d'inscription 18 janvier 2018 Dernière intervention - 20 oct. 2017 à 13:55
0
Utile
6
Bonjour

1) Ce n'est sans doute pas RECHERCHEV qu'il va falloir utiliser mais plutôt un dénombrement avec NB.SI.ENS ou une mise en forme conditionelle qui colore les lignes en plus

2) Les paires en A et N se retrouvent-elles sur les mêmes ligne dans les 2 feuilles ou pas ?

3) Postes un exemple de ton fichier sur cjoint.com, fais créer un lien que tu copies et reviens coller ici, et là on aura une base pour t'aider

Cdlmnt
Via
via55 8939 Messages postés mercredi 16 janvier 2013Date d'inscription 18 janvier 2018 Dernière intervention > edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 20 oct. 2017 à 18:24
edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 22 oct. 2017 à 18:34
Super merci ! Je regarde ça !
edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 23 oct. 2017 à 11:47
Hello

Du coup j'ai essayé cette formule =NB.SI.ENS($A:$A;$A3;$N:$N;$N3)<>NB.SI.ENS(colA;$A3;colB;$N3)
J'ai remplacé B par N car c'est cette colonne qui correspond pour cibler
Mais ça ne me colorise pas, cela m'écrit vrai ou faux dans la colonne (j'ai tapé dans une nouvelle colonne et ensuite j'ai étiré la formule jusqu'en bas).
J'ai mis exprès une ligne "test" avec une ligne qui n'est forcément pas dans l'ancien fichier mais malgré tout la formule n'a pas reconnu l'erreur.

Aurais tu une idée ?

merci :)
via55 8939 Messages postés mercredi 16 janvier 2013Date d'inscription 18 janvier 2018 Dernière intervention > edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 23 oct. 2017 à 12:17
Bonjour

Sans voir le fichier difficile de dire
Poste un exemple de ton fichier avec ta formule comme le dernière fois
edes67 8 Messages postés jeudi 5 octobre 2017Date d'inscription 10 novembre 2017 Dernière intervention - 10 nov. 2017 à 13:57
J'ai pu trouver la solution grâce à un ami
Fonction Concatener pour créer la combinaison unique de chaque référence puis rechercheV pour les comparer

Merci pour ton aide Via!
Commenter la réponse de via55