Signaler

Problème formule si et.... [Résolu]

Posez votre question Nulosenformule - Dernière réponse le 14 oct. 2017 à 05:44 par PapyLuc51
Bonjour,

je galère de trop car pas trop (du tout même) doué pour les formules. Je sais qu'ils y en a qui adorent ça. Ce n'est vraiment pas mon cas. Voici mon problème :

j'ai :
cellule A1 : 1 cellule B1 : 2 cellule C1 : 3
en dessous, dans 3 autres cellules il y aurait le résultat des formules obtenues.

Je m'explique ça donnerai ça :
1 2 3
P M G

donc la formule pourrait être traduite ainsi :
si cellule A1 est inférieure à B1 et B2 alors P (qui veut dire que c'est le plus petit chiffre parmi les 3), sinon si A1>B1 et >B2 alors G (qui veut dire que c'est le chiffre le plus grand) et (si A1<B1 et >C3) ou (si A1>B1 et <C3 alors M (qui veut dire qu'il s'agit du chiffre situé entre les 2 autres en terme d'échelle de valeur).

J'espère que j'ai bien expliqué.

Du fond du coeur un grand merci d'avance pour ceux qui bosserait sur mon problème.
Utile
+1
plus moins
Bonjour

Une proposition en A2

=SI(MAX($A$1;$B$1;$C$1)=A1;"G";SI(MIN($A$1;$B$1;$C$1)=A1;"P";"M"))

à incrémenter vers la droite jusqu'à C2 en maintenant le clic enfoncé sur la poignée de recopie située sur l'angle inférieur droit de la cellule A2

Cordialement
Nulosenformule- 13 oct. 2017 à 21:31
Super génial, c'est exactement ça, vous êtes trop fort, bravo!

Un grand grand merci à vous vous me sauvez !!!!!

merci merci merci
Répondre
Nulosenformule- 13 oct. 2017 à 22:14
re,

quand je veux copier cette formule vers le bas cette formule :
=SI(MAX($A$1;$B$1;$C$1)=A1;"G";SI(MIN($A$1;$B$1;$C$1)=A1;"P";"M"))

cela ne change QUE A1 en A2 :
=SI(MAX($A$1;$B$1;$C$1)=A2;"G";SI(MIN($A$1;$B$1;$C$1)=A2;"P";"M"))

comment faire pour arriver à ceci ?
=SI(MAX($A$2;$B$2;$C$2)=A2;"G";SI(MIN($A$2;$B$2;$C$2)=A2;"P";"M"))

Merci
Répondre
Donnez votre avis
Utile
+1
plus moins
Bonjour,

Tu n'avais pas précisé cette intention dans ta question initiale.

Si tu veux recopier la formule vers le bas il faut retirer le blocage des numéros de cellule représenté par le signe $

=SI(MAX($A1;$B1;$C1)=A1;"G";SI(MIN($A1;$B1;$C1)=A1;"P";"M"))


Cordialement
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !