Formule SI et condition "plus petit" et "plus grand" [Résolu]

cavelavestave 66 Messages postés vendredi 8 mars 2013Date d'inscription 10 novembre 2017 Dernière intervention - 13 oct. 2017 à 11:29 - Dernière réponse : cavelavestave 66 Messages postés vendredi 8 mars 2013Date d'inscription 10 novembre 2017 Dernière intervention
- 13 oct. 2017 à 11:48
Bonjour,

Je cherche une formule qui calculerait un pourcentage selon l'âge de la personne.

Je m'explique :

Dans mon tableau, nous avons l'année en cours(A1), le nom de la personne (A3) l'année de naissance(B3) de la personne, un salaire brut(C3) et une cellule à calculer en fonction de l'âge (D3).

Plus bas, j'ai un second tableau avec les données, exemple :


(A6) De 20 à 29 ans | (B6) 2%
(A7) De 30 à 39 ans | (B7) 3%
(A8) De 40 à 49 ans | (B8) 4%


J'aimerais que la formule calcule A1-B3 pour obtenir l'âge, puis qu'en fonction de l'âge on est le bon taux utilisé, donc SI A1-B3 = >20<29 alors calcule-moi B6 * C3" mais si A1-B3 = >30<29 alors calcule-moi B7 * C3" etc...

En bref, si âge (A1-B3) est plus grand que 20 mais plus petit que 29 alors calcule B6*C3 mais si âge est plus grand que 30 mais plus petit que 39 alors calcule B7 * C3 et ainsi de suite.

J'ai essayé de l'écrire avec la formule Si, le problème est que la valeur si faux serait de passer à la formule suivante (tranche d'âge suivante) et je ne sais pas comment l'inscrire.

Vous voyez l'idée ? Merci de votre aide :)
Afficher la suite 
66Messages postés vendredi 8 mars 2013Date d'inscription 10 novembre 2017 Dernière intervention

4 réponses

Répondre au sujet
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Vaucluse le 13/10/2017 à 11:38
+1
Utile
1
Bonjour
simplement en plaçant les conditions dans l'ordre croissant

=C3*SI(DATEDIF(B3;$A$1;"y")<=29;$B$6;SI(DATEDIF(B3;$A$1;"y")<=39;$B$7;$B$8))

DATEDIF donne le nombre d'années complètes entre deux dates


mais par contre, vous ne dites pas ce que vous voulez éventuellement pour les + de 49 ans et les moins de 20?

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Cette réponse vous a-t-elle aidé ?  
cavelavestave 66 Messages postés vendredi 8 mars 2013Date d'inscription 10 novembre 2017 Dernière intervention - 13 oct. 2017 à 11:48
Bonjour, la proposition de fabien25000 correspond totalement à ce que je cherchais, dans ma demande je n'ai mentionné que 3 tranches d'âge mais la finalité va couvrir bien plus, ce n'est que pour l'exemple ;)

Merci beaucoup pour votre aide tout de même et belle journée :)
Commenter la réponse de Vaucluse
fabien25000 265 Messages postés mercredi 5 octobre 2016Date d'inscription 16 octobre 2017 Dernière intervention - 13 oct. 2017 à 11:37
0
Utile
1
Bonjour,

est-ce cela que tu cherches :

=SI(A1-B3>=40;B8*C3;SI(A1-B3>=30;B7*C3;SI(A1-B3>=20;B6*C3)))
cavelavestave 66 Messages postés vendredi 8 mars 2013Date d'inscription 10 novembre 2017 Dernière intervention - 13 oct. 2017 à 11:46
Ouiiiiiiiiiii ça marche parfaitement merci beaucoup, à force de chercher, j'allais trop loin ;) Merci merci merci ! :) Bonne journée !
Commenter la réponse de fabien25000