Signaler

Lk

Posez votre question sousouB94 2Messages postés jeudi 12 octobre 2017Date d'inscription 12 octobre 2017 Dernière intervention - Dernière réponse le 12 oct. 2017 à 16:15 par Whismeril
Bonjour
SI (etatAgentCourrant==etatAgent.Actif) ALORS
  DEBUT_SI
  SI ( (Annonce.typeService==typeServiceCourrant) OU (  ( contenu(listeServiceCompatible, Annonce.nomService)) == Faux  ) ALORS
   DEBUT_SI
   AFFICHER "L'agent a ignoré trivialement l'annonce "
    FIN_SI
  SINON
    DEBUT_SINON
      SI (etatServiceCourant==etatService.Deconnecte) ALORS
     DEBUT_SI
     SI (contenu(listeConfiance, Annonce.RefAgent)) ALORS
      DEBUT_SI
       conf ← listeConfiance.PREND_LA_VALEUR(Annonce.RefAgent)
       conf ← Confiance (conf.incrementerNm(), conf.incrementerNr(), conf.incrementerNc(), Annonce.RefAgent)
       listeConfiance.ajouter(Annonce.RefAgent, Conf)
       AFFICHER " L'agent a accepté l'annonce " 
      FIN_SI
     SINON
         DEBUT_SINON
           conf ← Confiance (1, 1, 0, Annonce.RefAgent)
           listeConfiance.ajouter(Annonce.RefAgent, Conf)
           AFFICHER " L'agent a accepté l'annonce "
         FIN_SINON
     FIN_SI
  FIN_SINON
FIN_SI
SINON
         DEBUT_SINON
      listeRefAgentConnecte.effacer()
      FIN_SINON
  
FIN_ALGORITHME

Utile
+0
plus moins
Bonjour

imagine que ton boulanger te demande si tu préfères le pain blanc ou complet.
Tu sors de la boulangerie et entres dans la boucherie en disant à qui veut l'entendre "Complet bien sûr ».

Personne ne va comprendre.

C'est exactement ce que tu as fait sur ce forum en cliquant sur le bouton vert "Créer une discussion". Pour répondre à une discussion il faut cliquer sur le bouton BLEU "Répondre".

Si ce bouton n'est pas visible c'est que la discussion est close et qu'on ne peut plus y répondre. En ce cas un lien vers la discussion d’origine est indispensable pour comprendre ce que tu racontes.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !