Signaler

Formule avec liste déroulante de choix

Posez votre question Moexcel 2Messages postés jeudi 12 octobre 2017Date d'inscription 12 octobre 2017 Dernière intervention - Dernière réponse le 12 oct. 2017 à 14:05 par DjiDji59430
Bonjour,
Sur une première feuille j’ai en colonne A, les noms de fournisseur, colonne B les adresse, colonne C les villes,etc....
sur une deuxième feuille, j ai une liste déroulante de choix qui se réfère à la colonne A de la première feuille (environ 1000 fournisseurs)
je cherche à faire apparaître les colonnes B,C ,etc.... sur la 2eme feuille à partir du choix de la colonne A, pourriez vous m’aider s’il vous plaît ?
Utile
+0
plus moins
Bonjour,

si ta recherche se fait en a1 et les resultats en b1; c1, etc

=recherchev(a1;feuil1!a1:c1000;2;0) pour les adresses

=recherchev(a1;feuil1!a1:c1000;3;0) pour les viles
etc ....

Cdlmnt
DjiDji59430 1678Messages postés samedi 19 avril 2008Date d'inscription 12 octobre 2017 Dernière intervention - 12 oct. 2017 à 12:12
Re

=recherchev(a1;feuil1!$a$1:$c$1000;colonnes($1:2);0)
a etirer
Cdlmnt
Répondre
Moexcel 2Messages postés jeudi 12 octobre 2017Date d'inscription 12 octobre 2017 Dernière intervention - 12 oct. 2017 à 13:38
ok merci j'ai compris pour figer les cellule $, j'ai adapté à mon fichier du coup la formule fonctionne et est la suivante : =RECHERCHEV(A3;'bases fournisseurs'!$A$3:$C$102;2;0), par contre lorsque la collone A... n'est pas renseigné les réponse des colonnes B,C,etc... sont les suivantes : #N/A , pourtant la formule finit bien par ;0) j'ai essayé de remplacer par ;"") mais là sa me met #valeur
Répondre
DjiDji59430 1678Messages postés samedi 19 avril 2008Date d'inscription 12 octobre 2017 Dernière intervention - 12 oct. 2017 à 14:05
=Sierreur(recherchev($a3;feuil1!$a$3:$c$102;colonnes($1:2);0);"")

Cdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !