Signaler

Mise en forme conditionnelle possible avec des couleurs [Résolu]

Posez votre question Valerie54001 23Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - Dernière réponse le 12 oct. 2017 à 15:15 par Valerie54001
Bonsoir tout le monde,

J'ai une nouvelle fois besoin de vos lumières Raymond and Cie :)

Peut-on créer des règles du genre :

Si il y a plus de cellules de couleur verte que de cellules de couleur rouge alors 1
Si il y a plus de cellules de couleur rouge de cellules de couleur verte alors 2
Si il y a autant de cellules de couleur rouge que de cellules de couleur verte alors 3
Si il y a que des cellules de couleur verte alors 4
Si il y a que des cellules de couleur rouge alors 5

Attention il se peut que les cellules ne soient pas colorées donc elles ne doivent pas être prises en compte.

Ci-joint une image


Avec le fichier Excel :

http://www.cjoint.com/c/GJlrze5tHCd

Bonne soirée à vous.
Utile
+1
plus moins
Bonjour à tous les deux

Avec une fonction personnalisée (macro)
http://www.cjoint.com/c/GJlsf2MyQHB

Cdlmnt
Donnez votre avis
Utile
+1
plus moins
Salut, tout le monde.

Si Valérie préfère éviter la macro, elle devra colorer ses cellules à l'aide des règles de mise en forme conditionnelle, en saisissant "v" ou "r" et en laissant Excel effectuer la mise en couleur.
- Donner le nom "plaj" à la plage B2:C6
- Mettre les formules =NB.SI(plaj;"r") en G3 et =NB.SI(plaj;"v") en G4
- Donner le nom "CR" à la cellule G3 et "CV" à la cellule G4
Alors la formule en B8 sera :
=SI(CV>CR;1;SI(CR>CV;2;SI(CV=CR;3;SI(CR=0;4;SI(CV=0;5;0)))))

http://www.cjoint.com/c/GJmcO4BWj0B

Cordialement.
Valerie54001 23Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 12 oct. 2017 à 07:23
Merci ccm81 et les Antilles !

Les deux différents solutions sont super !

ccm81, comment dans ta macro , tu fais pour définir la zone ( s'il vient a en avoir une ) de couleur à traiter (B2:C6) ?
Répondre
ccm81 8120Messages postés lundi 18 octobre 2010Date d'inscription 17 octobre 2017 Dernière intervention - 12 oct. 2017 à 13:41
Ce n'est pas la macro qui définit la zone, mais la plage passée à la fonction ok dans formule (dans la feuille)
=ok(B2:C6)
ex si la zone à traiter est B2:G20
=ok(B2:G20)
Répondre
Valerie54001 23Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 12 oct. 2017 à 15:15
Merci ccm81.
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour Valérie la Lorraine.

Comme d'habitude, on ne peut pas fournir une formule précise alors qu'on ne connaît pas les références (ligne/colonne) de tes cellules.
Il ne sert pas à grand-chose d'envoyer une image (capture d'écran).
C'est le fichier Excel qu'il nous faut.
Ainsi, tu parles de cellules rouges, et il n'y en a pas dans ton image (on devrait en voir 4).
Enfin, on ignore comment elles sont colorées : à la main ou par mise en forme conditionnelle ? Dans le premier cas, il te faudra une macro ...

Cordialement.
Valerie54001 23Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 11 oct. 2017 à 19:28
Bonsoir mon bon Raymond,

j'ai modifié le sujet d'origine avec l'ajout d'un fichier.

Les couleurs sont mises à la main.

En fait Raymond, j'avais commencé le sujet de base avec les mêmes couleurs.

Bonne soirée
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !