Signaler

Formule Conditions SI [Résolu]

Posez votre question bgee2000 6Messages postés vendredi 15 août 2003Date d'inscription 11 octobre 2017 Dernière intervention - Dernière réponse le 11 oct. 2017 à 12:47 par bgee2000
Bonsoir a tous,
Voilà le probleme:
Colonne A : Valeur alternative de "B" et de "P"
Colonne B : Valeur alternative de "S" et "O"
Colonne C: Si "B" dans la colonne A et "S" (=same) alors la valeur a indiquer = "B" (idem pour P)
ET
Si "O" dans la colonne B: il me faut la lettre "opposé", donc si c'est B, il faut que P apparaisse. (Si c'était un P il faudra retourner la valeur "B")
pourriez vous m'aider a écrire cette formule svp?
merci d'avance,

Bgee

--
Utile
+2
plus moins
Bonsoir bgee2000,

Je te propose cette formule :

=SI(B1="S";A1;CAR(146-CODE(A1)))

----------------------------

Si A1 et / ou B1 peuvent être vides, utilise plutôt :

=SI(OU(A1="";B1="");"";SI(B1="S";A1;CAR(146-CODE(A1))))

Cordialement
Donnez votre avis
Utile
+0
plus moins
Bonsoir

=SI(ET(OU(A1="B";A1="P");B1="S");C1="B";SI(ET(A1="B";B1="O");C1="P";SI(ET(A1="P";B1="O");C1="B")))
Raymond PENTIER 43791Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 11 octobre 2017 Dernière intervention - 11 oct. 2017 à 04:09
Attention, Fabien !
C'est dans la cellule C1 que tu écris ta formule et donc que s'affichera le résultat !
Tu aurais dû écrire simplement :
=SI(ET(OU(A1="B",A1="P");"S");"B";SI(ET
(A1="B";B1="O");"P";SI(ET(A1="P";B1="O");"B")))
Répondre
fabien25000 243Messages postés mercredi 5 octobre 2016Date d'inscription 11 octobre 2017 Dernière intervention - 11 oct. 2017 à 06:39
Trés juste Raymond, je déchiffrais la question en écrivant la formule... ceci dit la formule de Paul est beaucoup beaucoup mieux!
Répondre
paul- 11 oct. 2017 à 11:03
Bonjour Fabien, merci du retour.
Répondre
Donnez votre avis
Utile
+0
plus moins
Ma formule, de taille intermédiaire entre les deux premières :
=SI(B1="S";A1;SI(B1="O";SI(A1="B";"P";SI(A1="P";"B";""));""))

Je tiens à féliciter paul pour son astucieuse formule, que les débutants en Excel auront du mal à comprendre, mais qui est courte et efficace !
paul- 11 oct. 2017 à 11:04
Bonjour Raymond, merci du retour.
Répondre
Donnez votre avis
Utile
+0
plus moins
Super, ça fonctionne parfaitement, merci raymond (et a tous!)

--
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !