Recherchev ne reconnait pas format ? [Résolu]

hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 9 oct. 2017 à 14:15 - Dernière réponse : Vaucluse 20864 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention
- 10 oct. 2017 à 12:29
Bonjour à tous,

la recherchev ne reconnait pas le format entre deux feuilles avec formule ci dessous
SI(A2="";"";SI(NB.SI(Feuil2!A:A;A2);RECHERCHEV(A2;Feuil2!A:C;3;0);"0"))
c'est systématiquement 0
quand je fais un coller copier du texte cellule de feuil2 à feuil1,cela me donne la bonne valeur
que ce passe t'il et surtout comment y remedier
a vous lire
d'avance merci
Afficher la suite 

7 réponses

Répondre au sujet
Vaucluse 20864 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention - Modifié par Vaucluse le 9/10/2017 à 16:17
0
Utile
2
Bonjour
c'est probablement parce que votre colonne de valeurs cherchées en feuil2 A:A contient des blancs avant ou après le texte, ou alors, s'il s'agit de valeur numériques, elles sont en texte plutôt qu'en num.
Mais sans en connaitre plus sur vos données, difficile de conclure: texte, num?
si vous pouvez déposer un modèle ici:
http://mon- partage .fr
et revenir ici coller le lien créé sur le site, on pourra vous dire ce qu'il se passe.

en attendant, essayez avec:

=SI(A2="";"";SI(NB.SI(Feuil2!A:A;"*"&A2&"*");RECHERCHEV("*"&A2&"*";Feuil2!A:C;3;0);"0"))

qui ne tiendra pas compte des blancs éventuels dans la colonne de recherche

à vous lire
crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 10 oct. 2017 à 11:24
bonjour vaucluse,

la formule ci dessus que vous me proposée ne fonctionne pas et me donne resultat zero
et maintenant, le copier collé me donne #REF!
je vous ai déposé le fichier comme sugéré (http://mon- partage .fr)
merci de votre aide
bien cordialement
Vaucluse 20864 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention > hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 10 oct. 2017 à 11:30
vi.. mais en fait, là vous me donnez l'adresse du site, pas le lien pour accéder à votre fichier
Enregistrez e fichier sur le site (en haut) créez le lien (en bas) copiez le (en haut) et revenez le coller ici
en ce qui concerne le #REF dans le collage, peut être est ce parce que vous n'avez pas de feuille dans le fichier du nom exact de Feuil2
(je l'ai collée chez, moi et elle fonctionne)
A vous lire
crdlmnt
Commenter la réponse de Vaucluse
hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 10 oct. 2017 à 11:43
0
Utile
vaucluse,

voila le lien
je vais reassayer la formule !

https://mon-partage.fr/f/qfLG8lAB/

bonne reception

cdlt
Commenter la réponse de hbubus
Vaucluse 20864 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention - Modifié par Vaucluse le 10/10/2017 à 12:27
0
Utile
2
Vu le fichier
Conclusions:
votre formule en D3
=SI(A3="";"";SI(NB.SI(Feuil2!A:A;A3);RECHERCHEV("*"&A3&"*";Feuil2!A:A;2;0);"ref non entrée"))

dans le code NB.SI manque (.......!A:A:"'*"&A3&"*").....
dans le code RECHERCHEV Feuil2!A:A à remplacer par Feuil2!A:B si vous voulez ressortir la valeur de la seconde colonne du champ
(c'est de là que vient le #REF puisque vous demandez la 2° colonne d'un champ qui n'en a qu'une)

corrigez ça et ça va aller mieux

et effectivement vous avez en feuil2 colonne A des codes qui sont suivis d'un certain nombre de blancs qui sont à l'origine de votre problème
(pour voir ça , placez le curseur en début d'un texte dans la barre de formule et glissez vers la droite en maintenant pour voir jusqu'où va l'ombrage qui représente l'ensemble et voyez l'espace qui le sépare de la fin du texte)

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 10 oct. 2017 à 12:27
vaucluse,
ayant reessayé la formule conseillée,celle ci fonctionne sur la plupart des cellules (90%)
je considere cela comme resolu et vous remercie vivement de votre aide et du temps precieux que vous me faite gagner
encore un grand merci à tous ceux qui donnent de leur temps pour nous assister
sur ce site
bien cordialement
Vaucluse 20864 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 15 décembre 2017 Dernière intervention > hbubus 14 Messages postés mercredi 10 septembre 2014Date d'inscription 19 octobre 2017 Dernière intervention - 10 oct. 2017 à 12:29
alors c'est OK, les 10% qui restent doivent surement provenir d'erreur d'écriture dans les codes ; Excel, lui ne se trompe pas sur 10% seulement!:-))
bonne route
crdlmnt
Commenter la réponse de Vaucluse