Fonction Indirect Ext Erreur Nombre

Valentino - 4 oct. 2017 à 17:27 - Dernière réponse : DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention
- 5 oct. 2017 à 15:41
Bonsoir,

Je rencontre un problème avec un fichier.
Celui centralise pour chaque société (250 au total) les notes obtenues selon différents critères. Toutes ces notes sont localisées sur des feuilles excel différentes dans des fichiers externes. Ainsi, pour récupérer la note d'un critère, il faut que je fasse référence à une cellule dans une feuille spécifique. La structure de ces fichiers excel externes est identique pour toutes les sociétés.
J'ai donc mis en marche une macro qui me permet d'utiliser Indirect Ext pour récolter toutes ces notes. Malheureusement, pour les critères d'une feuille, j'obtiens le message d'erreur #Nombre. Je n ecomprends pas pourquoi, car la formule semble identique pour tous les autres critères. Seule la référence de feuille excel a changé (ce qui est normal car la note se trouve à une feuille différente)

Voici la formule utilisée :
=SOMME(IndirectEx("'I:\users\ISR\CG 2017\Mid Caps\Grilles\["&C3&".xlsm]C1'!$C$6:$C$8"))

Elle permet d'aller dans les dossiers chercher la note obtenue dans la feuille C1 du fichier considéré. Le C3 de la formule correspond au nom du fichier.

L'erreur nombre apparaît avec la formule suivante :

=SOMME(IndirectEx("'I:\users\ISR\CG 2017\Mid Caps\Grilles\["&C3&".xlsm]C8'!$C$6:$C$8"))

Je cherche la note obtenue dans la feuille C8 du même fichier. Mais Excel me répond l'erreur #Nombre

Les notes sont récupérés aux onglets C1,C2,C3 etc.. C8, C9,C10. Seul C8 pose problème.

Toute aide est la bienvenue.
Je vous remercie.
Valentin
Afficher la suite 

10 réponses

Répondre au sujet
DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention - 4 oct. 2017 à 18:02
0
Utile
1
Bonjour,

Regarde si le C8 de ton onglet et celui de ta cellule C3 sont identiques.Si l'un des deux n' a pas un espace en plus.

Cdlmnt
Bonjour,

Merci pour la piste, mais C3 (le nom du fichier) est identique pour toutes les feuilles (C1,C2,C3,C4 etc.). Si je crée un nouvel onglet C11 et que je transfère les notes, la référence marche. C'est donc un problème avec l'onglet C8, mais je n'arrive pas à le déceler.

Cordialement,
Valentin
Commenter la réponse de DjiDji59430
eriiic 21187 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 4 oct. 2017 à 19:25
0
Utile
7
Bonjour,

regarde aussi si les cellules concernées ont bien des nombres (alignés à droite) et non du texte (aligné à gauche).
Bien sûr enlever tout centrage ou alignement forcé avant.
eric
eriiic 21187 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 5 oct. 2017 à 09:12
Bonjour,
Tu as essayé quoi ?
Il s'agit d'un contrôle, rien à essayer.
Tu enlèves tous les alignements sur C8'!$C$6:$C$8 et tout doit être à droite.
eric
J'ai enlevé tous les alignements, mais cela ne résout pas le problème malheureusement.
Cordialement,
eriiic 21187 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - 5 oct. 2017 à 12:05
La question est : est-ce que tous les nombres s'alignent bien à droite ???
Oui, tous les nombres s'alignent bien à droite dans C8'!$C$6:$C$8
DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention > Valentino - 5 oct. 2017 à 15:41
Bonjour,

Il ne te reste plus qu'a mettre le fichier sur le forum !

Cdlmntw
Commenter la réponse de eriiic