Pourcentage [Résolu]

Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 3 oct. 2017 à 19:03 - Dernière réponse : Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention
- 4 oct. 2017 à 11:23
Bonjour la communauté,

je tombe sur un os.

Dans le fichier (http://www.cjoint.com/c/GJdq6ZpYu0f) j'essaie de réaliser un pourcentage sur le nombre de fois que Pierre et Marie mangent des fruits et légumes par jour.

Je n'arrive pas à faire comprendre comment faire pour compter le nombre de fois les différents prénoms et en tirer le pourcentage car je travaille avec des Noms et non pas des nombres.

je n'ai rien trouver dans les astuces ou bien sur le fofo.

Avez-vous une idée?

Valérie
Afficher la suite 

13 réponses

Répondre au sujet
+1
Utile
Bonjour Valerie54001,

Je te retourne ton fichier Excel modifié :
https://mon-partage.fr/f/jkfaByAs/

Merci de me dire si ça te convient.

Cordialement
 
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de julien
Vaucluse 21023 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 janvier 2018 Dernière intervention - 4 oct. 2017 à 10:48
+1
Utile
1
Voila voila
https://mon-partage.fr/f/0pJCdOpF/

crdlmnt
Cette réponse vous a-t-elle aidé ?  
Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 4 oct. 2017 à 11:23
Merci Vaucluse !

Cette solution est idéale.

Merci à vous tous !
Commenter la réponse de Vaucluse
Vaucluse 21023 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 janvier 2018 Dernière intervention - 3 oct. 2017 à 19:11
0
Utile
Bonjour
que voulez vous faire exactement
  • à quoi correspond votre tableau qui comporte les mêmes noms en titre de colonnes et en bout de lignes?
  • où sont les nombres de fois pour légumes et pour fruits?
  • des % par rapport à quoi?

à vous lire
crdlmnt

Commenter la réponse de Vaucluse
Raymond PENTIER 44819 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 15 janvier 2018 Dernière intervention - 3 oct. 2017 à 20:13
0
Utile
1
Valérie,

emportée par l'émotion, tu as écrit Pierre et Marie en A1 et B1 à la place de "Fruits" et de "Légumes", je suppose ?

Par ailleurs tu calcules bien sur des nombres, puisque tu t'intéresses aux nombres saisis en A2:B5 ...

Sur les 28 fruits et légumes consommés, 75% l'ont été par Pierre et 25% par Marie :
=SOMME(A3:B5)/SOMME(A2:B5) en E3
=SOMME(A2:B2)/SOMME(A2:B5) en F3
Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 3 oct. 2017 à 20:16
Raymond,

J'ai mis mon fichier à jour pour être plus claire.

cdt.
Commenter la réponse de Raymond PENTIER
Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 3 oct. 2017 à 20:14
0
Utile
Bonjour Vaucluse,

j'ai mis le fichier à jour.

http://www.cjoint.com/c/GJdsnMYYUX4

cdt.
Commenter la réponse de Valerie54001
via55 8927 Messages postés mercredi 16 janvier 2013Date d'inscription 14 janvier 2018 Dernière intervention - 3 oct. 2017 à 20:27
0
Utile
Bonjour à tous

En D2 : =SI(B2>C2;"Pierre";SI(B2<C2;"Marie";"Egalité")) puis étirer vers le bas

En F2 : =NB.SI(D2:D5;F2)/NBVAL(D2:D5)
Adapter ensuite cette formule pour G2

Cdlmnt
Via
Commenter la réponse de via55
Vaucluse 21023 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 janvier 2018 Dernière intervention - 4 oct. 2017 à 07:47
0
Utile
Bonjour Valérie
une proposition ici:
https://mon-partage.fr/f/QNFNd2Bg/
crdlmnt
Commenter la réponse de Vaucluse
Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 4 oct. 2017 à 09:11
0
Utile
Bonjour à tous,

tout d'abord merci à vous tous pour votre réactivité.

Vos propositions m'ont fait avancée dans mon raisonnement,
j'ai rajouté une case " NUL " en cas d'égalité.

Par contre , le total de Pierre , Marie et Nul doit bien faire 100%.

https://mon-partage.fr/f/uHCWk8JZ/

Je bidouille depuis la proposition de Vaucluse mais je reste bloquée.

Bonne journée à tous
Commenter la réponse de Valerie54001
mdo100 96 Messages postés jeudi 9 décembre 2010Date d'inscription 4 janvier 2018 Dernière intervention - 4 oct. 2017 à 10:45
0
Utile
1
Bonjour à toutes et tous,

Voir cette proposition avec comme raisonnement que:
Si Pierre & Marie sont exæquo cela revient donc à une valeur nul, donc pour moi elle ne rentre pas en compte dans le calcule du partage en pourcentage de la répartition entre Pierre & Marie.

J'ai nommée la plage résultat dans le "Gestionnaire de noms" et j'ai ajouté une formule dans la colonne "A" avec un "format de cellule personnalisée".

http://www.cjoint.com/c/GJeiLOWcDou

Cordialement.
Valerie54001 23 Messages postés mardi 22 novembre 2016Date d'inscription 13 octobre 2017 Dernière intervention - 4 oct. 2017 à 11:22
Bonjour mdo100,

j'avais besoin que les ex quo , NUL, soit pris en compte.

Cdt.
Commenter la réponse de mdo100
Raymond PENTIER 44819 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 15 janvier 2018 Dernière intervention - 4 oct. 2017 à 00:26
-1
Utile
Eh bien, Valérie, il aurait fallu des talents de devin pour comprendre, à partir de ton message de départ, que c'est de cela qu'il s'agissait !

La proposition de julien a l'avantage d'ajouter un cas que tu n'as pas indiqué, mais qui peut se produire : même quantité pour les 2 personnes.
Commenter la réponse de Raymond PENTIER