Fonction recherchev

emmap68 4 Messages postés dimanche 4 mai 2014Date d'inscription 3 octobre 2017 Dernière intervention - 3 oct. 2017 à 11:41
Bonjour,
ma formule recherchev ne fonctionne pas
j'ai essayé en modifiant les formats tous en texte ou tous en nombre, sans succès.
j'ai utilisé la fonction esterreur pour corriger le format, sans succès.

une autre solution ?

en feuille 1 :
2 colonnes : la 1ère pour ma recherchev, la 2nde avec des données "référence"
=RECHERCHEV(B2;table;2;0)
3082851
5208746
8260081
etc...

en feuille 2 :
2 colonnes avec des données et dans la 2ème colonne il y a plusieurs lignes pour la même référence
Service référence
150 6923717
150 8231367
150 15904643
150 15904643
150 15904643

j'ai créé un tableau croisé (table de pilote) qui m'ouvre une 3ème feuille avec le nombre de lignes par référence :
référence NB - référence
6923717 1
8231367 1
15904643 7
j'ai nommé table ces 2 colonnes de la 3ème feuille (comme matrice)

Je veux donc ajouter la donnée "nombre de référence" dans la colonne 1 de ma 1ère feuille

pas moyen !
NB : il y a plus de références dans ma feuille 1, et des références différentes dans les 2 feuilles (certaines références de la feuille 1 ne se trouvent pas dans la feuille 2, et également certaines références de la feuille 2 ne figurent pas dans la feuille 1).
je veux juste que lorsqu'il y a une référence de la feuille 1 commune avec 1 référence de la feuille 2, le nombre de référence pour celles communes soit indiqué.

je peux transmettre mon fichier pour mieux comprendre ...

merci d'avance

( j'ai la version libre office 4.3.7.2)
Afficher la suite