Signaler

Fonction SI [Résolu]

Posez votre question Lachagne1 4Messages postés lundi 2 octobre 2017Date d'inscription 3 octobre 2017 Dernière intervention - Dernière réponse le 3 oct. 2017 à 06:48 par Lachagne1
Bonjour,

Voilà mon soucis : SI A1 contient FRANCE; B1 = FR (Par exemple, ça je sais faire)
MAIS : SI A1 contient FRANCE; B1 = Le résultat obtenu en B2 (Là, je bug)

Merci par avance de l'aide que vous m'apporterez.
Utile
+0
plus moins
C'est très compliqué !
Mais on va quand même essayer, avec cette méga-formule en B1 :
=SI(A1="FRANCE";B2;"")
Vérifie si ça marche ...
Donnez votre avis
Utile
+0
plus moins
Merci Raymond, ça fonctionne du 1er coup. Néanmoins, je me permets d'aller un peu plus loin.
La même formule, mais avec 2 choix.

SI A1 contient FRANCE ; B1 = le contenu de B2 (on sait que ça fonctionne, encore merci) ; mais si A1 contient SUISSE ; B1 = le contenu de B3
Donnez votre avis
Utile
+0
plus moins
C'est cool Raymond, j'ai trouvé la solution. Merci encore et profite des Antilles, c'est magnifique.
Raymond PENTIER 43791Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 11 octobre 2017 Dernière intervention - 3 oct. 2017 à 04:15
Merci de tes remerciements ...

Pour me rassurer, malgré tout, et comme tu n'as pas indiqué quelle formule tu avais trouvée, je te donne quand même la solution :
=SI(A1="FRANCE";B2;SI(A1="SUISSE";B3;""))
en espérant que tu n'as pas une quarantaine de pays à gérer ainsi ...
Répondre
Donnez votre avis
Utile
+0
plus moins
Oui c'est la formule que j'avais trouvé. Et non je n'ai pas une 40aine de pays a gérer. C'était mon exemple. En réalité c'est cadre ou non cadre et deux taux de charges patronales différentes. Cela dit en passant, j'ai remplacé cadre et non cadre par oui et non, car si j'inscrit non cadre, le fait que la cellule contienne le mot cadre, ça m'inscrit la mauvais taux. Mais cela n'a aucune incidence. Bonne continuation au soleil, en espérant que tu n'as pas trop souffert d'Irma.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !