Signaler

Mettre en italique nombreux mots encadrés <em> </em> word [Résolu]

Posez votre question GuillaumeOK 6Messages postés samedi 30 septembre 2017Date d'inscription 1 octobre 2017 Dernière intervention - Dernière réponse le 1 oct. 2017 à 22:31 par GuillaumeOK
Bonjour,

J'ai un très gros fichier à mettre en forme sur Word 2013.
Dans ce fichier il y a énormément de termes qui figurent ainsi <em>Chthamalus montagui</em>.
Ces termes sont encadrés par <em> et </em>
Je voudrais savoir svp, comment les mettre en forme automatiquement, de telle sorte que "Chthamalus montagui" apparaissent en italique.
A la main, un par un c'est hyper long et je risque d'en oublier. Je n'ai pas vu de discussion similaire sur le forum.

Merci pour votre aide.
Cordialement
Guillaume

Utile
+1
plus moins
Salut,


Je n’ai pas Word sous la main, mais tu peux essayer un CTRL+H.

Ça permet de remplacer du texte par un autre texte. Dans ton cas, tu peux chercher "<em>*</em>" et le remplacer par "*" (où « * » correspond au texte entre les balises <em>.

Dans LibreOffice (qui n’est pas Word mais qui y ressemble) je peux également spécifier le formatage à ajouter au texte remplacé.

Il me suffit donc d’utiliser cet outil de remplacement et de dire que je veux que le texte remplacé soit en italique.


Je pense que Word permet de faire la même chose.


Ça donne ça : https://lehollandaisvolant.net/img/a7/capture-du-2017-09-30-18-06-36.png


(Pour info, ce que tu cherches à faire, c’est un "chercher/remplacer" avec formatage et des REGEX, ce dernier permettant de chercher des choses comme « [0-9] » (qui cible tous les chiffres) ou « [a-z] » qui cible toutes les lettres, sans avoir à spécifier une à une les lettres ou les chiffres :). C’est assez pratique)
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 30 sept. 2017 à 18:15
Après une petite recherche pour Word, il faut utiliser la méthode de rechercher/remplacer (CTRL+H) puis mettre ça :

Dans le champ "rechercher" :
\<em\>(*{1,})\</em\> 


Et ça dans remplacer :
\1


Il faut cocher une case qui se nomme "use wildcard" en anglais et qui en français serait "utiliser joker" ou "utiliser caractère générique".

Et il faut activer un remplacement du style (en choisissant de remplacer ton texte par de l’italique).


Sources :

https://support.office.com/fr-fr/article/Rechercher-et-remplacer-du-texte-ou-une-mise-en-forme-dans-Word-pour-Mac-ac12f262-e3cd-439a-88a0-f5a59875dcea

https://stackoverflow.com/questions/24308538/find-and-replace-with-regex-in-microsoft-word-2013
Répondre
GuillaumeOK 6Messages postés samedi 30 septembre 2017Date d'inscription 1 octobre 2017 Dernière intervention - 30 sept. 2017 à 19:05
Merci pour vos infos.
Je viens de tenter à plusieurs reprises, mais ça ne marche pas.

Peut-être que ma question n'est pas assez clair, je voudrais que tous les termes qui apparaissent ainsi :

<em>Chthamalus montagui</em>

deviennent ainsi dans le texte :

Chthamalus montagui
Répondre
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 30 sept. 2017 à 19:14
Oui, j’avais bien compris la question :)

Peux-tu me donner la version de Word que tu utilises ? 2007 ? 2010 ? 2013 ?

Ensuite, quand tu fais CTRL+H, il faut aller sur le "Plus" de la fenêtre (celle en bas à gauche sur cette image).
Répondre
Donnez votre avis
Utile
+0
plus moins
Et si, tout simplement, tu utilisais ctrl+H pour remplacer
em
par
italique
?
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 30 sept. 2017 à 19:29
Cela remplacerait le texte seulement.

Cela ne remplacerait pas du texte "<em>" par du formatage réellement en italique.

Sans compter que ça remplacera aussi les "em" dans les autres mots. Par exemple le mot « exemple » deviendra « exitaliqueple » (à cause du "em" qui s’y trouve).
Répondre
Donnez votre avis
Utile
+0
plus moins
Je vous prie tous de m'excuser : J'ai répondu comme s'il s'agissait d'un message dans CCM, et non d'un document Word.
Je suis confus !
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 30 sept. 2017 à 19:56
Ah d'accord, ce n'est pas grave :)
Répondre
Donnez votre avis
Utile
+0
plus moins
Bon, je viens d’essayer sur Word 2016 :

1)
Faire CTRL+H

2)
Mettre dans Rechercher :
\<em>(*{1})\<em\>

Mettre dans Remplacer :
\1


3)
Cliquer sur le "plus"

4)
Cocher le "utiliser les caractères génériques"

Comme là : https://lehollandaisvolant.net/img/22/word.png

5)
Se positionner dans le champ "Remplacer par" (en cliquant dessus).
Puis cliquer sur "Format" (en bas de la fenêtre) et aller sur "Police" puis cliquer sur "Italique" dans la colonne centrale.

Comme là : https://lehollandaisvolant.net/img/33/word.png

6)
"Ok" puis "remplacer tout"

7)
Le texte est alors remplacé et le résultat est en italique :
https://lehollandaisvolant.net/img/71/word.png
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 30 sept. 2017 à 21:40
Je viens de voir : dans mon post il y a une erreur.

Il faut chercher :

\<em\>(*{1})\<em\>




Si ça ne marche toujours pas, essayer ça :
\<em\>(*{1,})\<em\>

ou ça :
\<em\>(*)\<em\>


De toute façon, la méthode est celle décrite.
Si ça ne marche pas, c’est qu’il y a un soucis avec le code qu’on rentre dans le champ de recherche (la REGEX).
Répondre
GuillaumeOK 6Messages postés samedi 30 septembre 2017Date d'inscription 1 octobre 2017 Dernière intervention - 30 sept. 2017 à 22:15
Merci. Alors ça marche un peu, mais pas complètement. Certains termes sont changés en italique mais pas d'autres.

Par exemple je passe de :

<em>Mytilus edulis</em> et balanes sur roche médiolittorale très exposée
<em>Chthamalus</em> spp. sur roche exposée du médiolittoral supérieur
<em>Chthamalus montagui</em> et <em>Chthamalus stellatus</em> sur roche exposée du médiolittoral supérieur
<em>Chthamalus</em> spp. et <em>Lichina pygmaea</em> sur roche escarpée et exposée du médiolittoral supérieur

à un résultat qui donne ça avec la manip \<em\>(*{1})\<em\> (les deux autres codes marchent pas) :

<em>Mytilus edulis</em> et balanes sur roche médiolittorale très exposée
<em>Chthamalus</em> spp. sur roche exposée du médiolittoral supérieur
Chthamalus montagui</em> et Chthamalus stellatus</em> sur roche exposée du médiolittoral supérieur
Chthamalus</em> spp. et Lichina pygmaea</em> sur roche escarpée et exposée du médiolittoral supérieur
Répondre
GuillaumeOK 6Messages postés samedi 30 septembre 2017Date d'inscription 1 octobre 2017 Dernière intervention - 30 sept. 2017 à 22:27
EN fait, je viens de regarder en détail là où ça marche on dirait que c'est lorsque il y a plusieurs terme à passer en italique qui se succèdent (séparés seulement par une virgule ou un "et") et des fois ça marche aussi sur des termes isolés en fin de phrase mais pour une raison incompréhensible pour moi tout ça.
Répondre
le hollandais volant 5010Messages postés samedi 8 mars 2008Date d'inscription 14 octobre 2017 Dernière intervention - 1 oct. 2017 à 19:08
On dirait que ce site (CCM) ne retranscrit pas le code correctement.

J’essaye encore une fois :

\<em\>(*{1})\</em\>


Il faut bien-sûr que le second "em" ait un slash devant.

Si ça ne marche pas, essaye ça :

\<em\>(*{1})\<\/em\>


(avec un anti-slash devant le slash).

En tout cas, on est sur la bonne voie : ça marche déjà un peu mieux.
Répondre
GuillaumeOK 6Messages postés samedi 30 septembre 2017Date d'inscription 1 octobre 2017 Dernière intervention - 1 oct. 2017 à 22:31
MERCI BEAUCOUP pour votre aide et votre persévérance !
ça MARCHE NICKEL !
Bonne soirée.
Guillaume
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !