Recherche formule [Résolu]

MJ - 27 sept. 2017 à 17:53 - Dernière réponse :  MJ
- 27 sept. 2017 à 21:11
Bonjour,

Je vais tenter d'être précise.

J'ai un fichier Excel

Les prix varient selon les produits et les mois.

J'aimerais une formule qui me permettrait de modifier le prix en fonction du produit et du mois

Merci
Afficher la suite 

5 réponses

Répondre au sujet
Vaucluse 20874 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - 27 sept. 2017 à 17:59
0
Utile
Bonjour
alors la tentative n'est pas trop réussie! enfin, on voit ce que vous voulez mais on ne sait pas comment vous répondre, faute de connaitre l'organisation de vos données.
avez vous un fichier modèle à soumettre (avec quelques explications )
ici:
http://mon-partage.fr
en revenant ici coller le lien créé sur le site

à vous lire
crdlmnt
Commenter la réponse de Vaucluse
0
Utile
https://mon-partage.fr/f/XpogiOQ7/

Voici le lien, en espérant que cela sera plus précis.
Commenter la réponse de MJ
Vaucluse 20874 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 décembre 2017 Dernière intervention - Modifié par Vaucluse le 27/09/2017 à 19:57
0
Utile
on a le fiçhier, c'est déjà ça

mais ça manque quand même un peu (beaucoup) d'explications...

ne sachant pas trop ce que vous voulez faire, je vous propose une idée dans les conditions ci dessous, vous pourrez peut être l'adapter à vos besoins réels:
en K6, pour ressortir le prix correspondant du tableau S6:AC32, selon produit et mois

avec un code pour éviter un affichage d'erreur si les infos de références ne sont pas trouvées:

et sous conditions que vos titres en ligne S5 AC5 soient bien les noms de mois identiques à ceux de la colonne F (donc comme au début en S5 T5 etc.. avec janvier et février, sans l'info "coûts"

la formule en K6 donc, à tirer sur la hauteur:

=SIERREUR(INDEX($S$6:$AC$32;EQUIV($F6;$Q$6:$Q$32;0);EQUIV($D6;$S$5:$AC$5;0));"non trouvé")

Le code SIERREUR ne fonctionne qu'à partir de Excel 2007

à tirer sur la hauteur (attention aux signes $ aux bons endroits)
revenez avec plus d'info si ça ne va pas

crdlmnt





La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
0
Utile
Bonjour MJ,

Feuille "Calcul matériaux", formule en K6 (à mettre sur une seule ligne) :

=SIERREUR(RECHERCHEV(Tableau1[[#Cette ligne];[Produit]];Tableau3[[Produit]:[Service]];EQUIV(Tableau1[[#Cette ligne];[Mois]];{"janvier";"février";"mars";"avril";"mai";"juin";"juillet";"août";"septembre";"octobre";"novembre";"décembre"};0)+2;0);"")

La formule est longue car en colonne "Mois", tes mois sont en toutes
lettres => il faut convertir en numéro de mois correspondant.

C'est une formule pour toute la colonne "Coûts" ; tu peux ajouter un
format personnalisé pour éviter l'affichage des zéros ; attention :
à droite de la colonne AC, pas de colonne "Coût décembre" ! donc à
adapter au besoin.

Merci de me dire si ça te convient.

Cordialement
 
Commenter la réponse de lionel
0
Utile
Merci beaucoup! C'est exactement ce que j'avais besoin.

Au plaisir,

MJ
Commenter la réponse de MJ