Signaler

Somme si en comparant 2 colonne de date [Résolu]

Posez votre question bidounet84 327Messages postés jeudi 28 août 2008Date d'inscription 23 novembre 2017 Dernière intervention - Dernière réponse le 6 nov. 2017 à 13:22 par bidounet84
Bonjour,

Bonjour,
J'ai une colonne A avec des dates, une colonne B avec des et une colonne C avec une quantité.
Je voudrais faire un somme.si sur C, si A2 et supérieur à B2, A3 supérieur à B3...
Comment faire ?

Utile
+0
plus moins
Bonjour,

Voici la formule qui pourrait vous correspondre :
=SOMME.SI(A:A;">"&B:B;C:C)

Si cela ne fonctionne pas comme vous le souhaitez faites un signe
Donnez votre avis
Utile
+0
plus moins
Bonjour

Essaie ceci :
=SOMMEPROD((A1:A100>B1:B100)*(C1:C100))

Cdlmnt
Via
bidounet84 327Messages postés jeudi 28 août 2008Date d'inscription 23 novembre 2017 Dernière intervention - 27 sept. 2017 à 16:05
Comment je gère si on ne connaît pas la limite du tableau ?
Car en faisant =SOMMEPROD((A:A>B:B)*(C:C))
Cà me retourne une erreur
Répondre
Donnez votre avis
Utile
+0
plus moins
Bon j'ai adapté à mon fichier et je n'ai pris que les 2 premières lignes.
L'une respecte, pas l'autre.
Cela devrait me retourner 1 et çà me retourne 2.

La formule :
=SOMME.SI(C2:C3;">"&Q2:Q3;K2:K3)
diablo13800 944Messages postés jeudi 2 juillet 2015Date d'inscription 17 novembre 2017 Dernière intervention - 27 sept. 2017 à 16:32
En effet je viens de voir qu'il y a une erreur dans la condition et cela ne fonctionne pas....

Vous pouvez prendre la formule de Via55 et mettre des bornes supérieur très étendus si vous ne connaissez pas la limite du tableau
Répondre
Donnez votre avis
Utile
+0
plus moins
Juste un dernier point, cela fonctionne grâce à vos différentes contribution via cette formule :
=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15)*(BDD!J2:J770))


Donc la je somme J2 à J770

Je veux quasiment la même chose donc avec les mêmes condition à la différence que je ne veux pas une somme mais une moyenne.

Que dois-je changer ?
bidounet84 327Messages postés jeudi 28 août 2008Date d'inscription 23 novembre 2017 Dernière intervention - 27 sept. 2017 à 17:58
Je me suis mal exprimé, dans mon premier cas je voulais effectivement sommé la colonne J en fonction des critères dans la formule.
Dans ma cellule d'à côté au lieu de vouloir sommé J, je veux faire la moyenne en jour entre P et C si cela respecte les critères.
Répondre
Vaucluse 20734Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 novembre 2017 Dernière intervention - 27 sept. 2017 à 18:03
La formule proposée vous donne la moyenne des valeurs de J selon le nombre de lignes concernées

la partie diviseur de la formule, soit donc:

=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15))

vous donne le nombre de lignes répondant aux conditions

mais la moyenne en jours entre C et P, pouvez vous préciser de quoi il s'agit????

crdlmnt
Répondre
bidounet84 327Messages postés jeudi 28 août 2008Date d'inscription 23 novembre 2017 Dernière intervention - 27 sept. 2017 à 18:07
P et J sont des dates, l'idée c'est d'avoir la moyenne des écarts entre chaque ligne entre les dates P et J
Répondre
Vaucluse 20734Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 23 novembre 2017 Dernière intervention - 27 sept. 2017 à 18:35
pas tout compris, mais si c'est pour avoir la moyenne des écarts entre P et C quand les conditions sont remplies, essayez avec:
=SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15)*(BDD!P2:P770-BDD!C2:C770))/SOMMEPROD((BDD!P2:P770<>"")*(BDD!C2:C770<(BDD!P2:P770)-15))


voyez ici
résultat des formules en feuille EDIT
dans la feuille BDD, les colonnes en vert ne servent qu'au contrôle des résultats de EDIT

https://mon-partage.fr/f/ffjD21w1/
crdlmnt
Répondre
bidounet84 327Messages postés jeudi 28 août 2008Date d'inscription 23 novembre 2017 Dernière intervention - 6 nov. 2017 à 13:22
Après un mois de fonctionnement, la formule fonctionne bien et correspond au besoin des mes utilisateurs.
Merci.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !