Fantôme de la clé Usb [Résolu]

pg57 35 Messages postés jeudi 27 novembre 2008Date d'inscription 1 octobre 2017 Dernière intervention - 23 sept. 2017 à 00:13 - Dernière réponse : mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention
- 1 oct. 2017 à 22:10
Bonjour,


Depuis quelques temps, thunderbird dont je partage le profil avec la version portable pour Windows installée sur une clé, ne fonctionne plus sous ubuntu : profil inexistant ou inaccessible.

En cherchant par ci par là ce qui pouvait être la cause de dysfonctionnement j'ai découvert que ma clé Usb apparaissait deux fois dans
/media/pierre
: une fois sous son vrai nom : CLEPG16G et une autre occurrence nommée CLEPG16G1.

Sur la capture ci-dessous on voit les deux occurrences de la clé et j'ai affiché les propriétés de CLEPG16G. http://img-19.ccm2.net/6W5vMTwccUxpld11BhRegGWKnAI=/1294356b9a1e47ca8345cd3eef7d2cc1/ccm-ugc/fantome_cle_usb.gif

Le contenu de CLEPG16G n'est pas accessible et le volume ne peut être démonté.

Accéder au contenu de CLEPG16G1 ne pose aucun problème depuis l'explorateur de fichiers mais accéder à un fichier de la clé depuis l'historique d'une application (LibreOffice par ex) est impossible s'il n'a pas été ouvert auparavant depuis CLEPG16G1 dans l'explorateur.

Le volume CLEPG16G1 peut être démonté et la clé retirée mais son fantôme CLEPG16G est toujours là !

Comment me débarrasser de ce fantôme CLEPG16G ? Je suis linuxien débutant et ne voudrais pas commettre de bêtises.

Merci pour votre aide.

Bien cordialement.


Afficher la suite 
35Messages postés jeudi 27 novembre 2008Date d'inscription 1 octobre 2017 Dernière intervention

4 réponses

Répondre au sujet
pg57 35 Messages postés jeudi 27 novembre 2008Date d'inscription 1 octobre 2017 Dernière intervention - Modifié par mamiemando le 24/09/2017 à 18:49
0
Utile
Bonjour,

Merci mamiemando pour ta réponse que je reproduis ne la voyant pas sur le forum :
Bonjour,

J'ai l'impression que c'est plus que la clé n'est pas montée (quand tu ne parviens pas à y accéder depuis thunderbird/libreoffice...). Le fait de vouloir l'ouvrir dans ton explorateur de fichier doit la monter, ce qui te permet ensuite d'y accéder.

Vérification

Depuis un terminal, tu peux voir ce qui est actuellement monté avec la commande

mount | grep sd

Exemple :

/dev/sdb2 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/sdb3 on /home type ext4 (rw,relatime,data=ordered)
/dev/sda2 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)


Ici on voit que j'ai trois disques (/dev/sdb2, /dev/sdb3, et /dev/sda2 montés respectivement dans /, /home, et /boot/efi). Dans ton cas, ton disque USB apparaîtra aussi avec son point de montage (/media/...) quand il sera effectivement monté.

Du coup, il serait intéressant de voir si ma théorie est correct :
- quand la clé est branchée mais est "fantôme", est-elle effectivement montée ?
- quand tu lances ton explorateur de fichier, devient-elle effectivement montée ?

Résolution du problème

Par défaut, les disques amovibles ne sont pas montés automatiquement, notamment pour palier à certains risques de sécurité. Le comportement que tu observes me paraît donc normal.

En général quand tu insères un disque amovible (USB, CD...) ton environnement te permet de le parcourir via ton explorateur de fichier (sous-entendu, après l'avoir monté). C'est la manière la plus simple de monter un périphérique (quitte à fermer l'explorateur derrière).

Tu peux aussi configurer un automount afin d'éviter ça.

Bonne chance


J'ai suivi ton conseil et lancé la commande mount | grep sd. Voici ce que j'obtiens quand la clé usb est montée, elle apparaît sous le nom CLEPG16G1 alors que son vrai nom est CLEPG16G usurpé par le fantôme :

pierre@sandettie:~$ mount | grep sd
/dev/sda7 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/sda6 on /mnt/007B97C863269950 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdb1 on /media/pierre/CLEPG16G1 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)


Lorsque je retire la clé le fantôme est toujours là dans media/pierre mais inaccessible comme le montre la capture ci-dessous:
http://img-19.ccm2.net/pbA9-BHqFB9Lphvg637eulMyUHc=/78605624ac2147ad904e77a99341c923/tmp/impossible_lire_cle_fantome.png

Voici ce que donne la commande
mount | grep sd
la clé étant retirée :

pierre@sandettie:~$ mount | grep sd
/dev/sda7 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/sda6 on /mnt/007B97C863269950 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)


La ligne "
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
" que l'on retrouve dans les deux cas ne correspondrait-elle pas au fantôme ?

Comment se débarrasser de ce maudit fantôme ?

Cordialement
Commenter la réponse de pg57
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - Modifié par mamiemando le 24/09/2017 à 18:51
0
Utile
2
Merci mamiemando pour ta réponse que je reproduis ne la voyant pas sur le forum :

En fait la version que tu as reportée était ma première réponse mais en y réfléchissant je me suis dit que le problème était plus compliqué. C'est pour ça que je l'ai supprimée.

La ligne "gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)" que l'on retrouve dans les deux cas ne correspondrait-elle pas au fantôme ?

Je ne pense pas. Je pense d'ailleurs que cette ligne apparaîtra que tu aies monté la clé ou pas (ou même, qu'elle soit branchée ou pas). Si tel est le cas, cela confirme ce que je pense.

Comment se débarrasser de ce maudit fantôme ?

En gros voici comment je vois les choses :

- un périphérique amovible peut être monté a priori dans n'importe quel répertoire (par exemple
/media/usb
). Certains montages sont spécifiés dans
/etc/fstab


- au niveau thunderbird, j'imagine que tu as créé dans ton profil thunderbird (~/.thunderbird par exemple) un lien vers un certain point de montage (mettons
/media/toto
). Or maintenant la clé est par exemple montée dans
/media/pierre/CLEPG16G1
. Cette incohérence explique pourquoi thunderbird ne retrouve pas ses petits.

- quand tu es dans ton explorateur de fichiers, le disque usb est occupé car il est déjà monté quelque part

Voici maintenant comment je réglerais les choses.

Méthode 1 :

- Pour commencer, je vérifierais qu'il n'y a pas de ligne dans /etc/fstab qui peut parasiter le montage.

gksudo gedit /etc/fstab


- Ensuite je regarderais où ubuntu monte ta clé par défaut (on va dire /media/pierre).

mount  | grep sd


- Ensuite je virerais le point de montage obsolète. Par exemple si c'était
/media/usb
.

sudo rmdir /aaa/bbb


- Enfin, j'adapterais le(s) lien(s) symbolique(s) que tu as créé(s) dans ton profil thunderbird pour le faire pointer vers le nouveau point de montage.

Méthode 2 :

Afin une solution consiste supprimer le dossier qui correspond à l'ancien point de montage et créer à la place un lien symbolique qui pointe vers le nouveau point de montage. Ainsi, pas besoin de corriger ton profil thunderbird.

sudo rmdir /ancien/point/de/montage
sudo ln -s /nouveau/point/de/montage /ancien/point/de/montage


Bonne chance
pg57 35 Messages postés jeudi 27 novembre 2008Date d'inscription 1 octobre 2017 Dernière intervention - 1 oct. 2017 à 17:30
Bonjour,

Merci mamiemando pour tes explications et tes conseils mais tout cela me semblait bien compliqué pour le débutant que je suis et je n'osais pas trop me lancer dans ces lignes de commande que je n'étais pas sûr de bien maîtriser.
Entre-temps j'ai eu une solution plus à ma portée sur un autre forum : https://forum.ubuntu-fr.org/viewtopic.php?id=2015315 et le fantôme a enfin disparu.

Encore grand merci.

Bien cordialement,
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 1 oct. 2017 à 22:10
Ok supprimer l'ancien de point de montage était suffisant (cf début de la méthode 2). Le lien symbolique c'était pour être ceinture et bretelles au cas où certaines applications référençait l'ancien chemin.
Commenter la réponse de mamiemando