Signaler

Petite aide formule si imbriquées [Résolu]

Posez votre question V44C12 - Dernière réponse le 15 sept. 2017 à 21:43 par V44C12
Bonjour,
J'ai un petit souci à régler je bute dessus voilà une formule avec si imbriquées :

=SI(B1<200;0;SI(B1<1000;C1*C2/100-30;C1*C2/100))

Ca fonctionne mais j'aimerai au final que si B1 est supérieur 200 quoi qu'il arrive le résultat de la formule soit supérieur ou égal à 10....

est-ce possible ?
Merci
Utile
+1
plus moins
Bonjour

Essaies ceci
=SI(B1<200;0;MAX(10;SI(B1<1000;C1*C2/100-30;C1*C2/100)))

Cdlmnt
Donnez votre avis
Utile
+1
plus moins

Je me répète :
c'est exactement ce que fait la formule de ccm81 !

Tu ferais bien de faire des tests avec différentes valeurs de B1 en nous disant chaque fois
- ce que tu voudrais trouver (en jaune)
- ce que donne la formule (en rose).

Donnez votre avis
Utile
+1
plus moins
Bonjour V44C12,

Je te propose cette formule :

=SI(B1<200;0;MAX(10;C1*C2%-30*(B1<1000)))

Et vérifie avec différents tests et différentes valeurs,
comme le propose Raymond PENTIER.

Cordialement
 
Donnez votre avis
Utile
+0
plus moins
Merci c'est pas mal mais du coup ça ne calcul plus en dessous de 1000 pour B1 ça met 10 comme valeur et ca recommence à calculer normalement à partir de B1=1001. Le but serait que la valeur de la formule soit minimum 10 si B1>200 ..
Raymond PENTIER 43577Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 23 septembre 2017 Dernière intervention - 15 sept. 2017 à 17:46
Tu as dû mal recopier la formule de ccm81, qui donne effectivement 10 lorsque B1 est compris entre 200 et 1000 !
Recommence ...
Répondre
Donnez votre avis
Utile
+0
plus moins
Oui exactement, justement lorsque B1 est compris entre 200 et 1000 la valeur est forcé à 10 mais ce n'est pas ce que je souhaite.

J'aimerai juste que la valeur soit forcé 10 si B1 > 200 ET que le résultat total de la cellule < à 10. En gros on ne peut faire moins de 10 si B1>200 .... j'espère que mon charabia est compréhensible ...
Donnez votre avis
Utile
+0
plus moins
Merci beaucoup ccm81, Raymond PENTIER et denis, finalement la première était la bonne, ce sont mes valeurs qui étaient mauvaises. Ca fait plaisir d'avoir des conseils comme les vôtres.
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !