Signaler

Fonction MOYENNE.SI [Résolu]

Posez votre question sara-87 60Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - Dernière réponse le 15 sept. 2017 à 13:43 par Raymond PENTIER
Bonjour,

J’ai un petit souci avec la fonction MOYENNE.SI, je voudrais calculer les moyennes mobiles sur 8 heures à condition d’avoir au moins 6 des 8 valeurs.
J’ai essayé de calculer le nombre de valeurs qui sont supérieur a 6 dans une colonne, puis appliquer la fonction MOYENNE.SI pour calculer la moyenne ,mais le résultat du calcul n’était pas correct .
j'ai tout essayé pour trouver une solution mais je ne sais pas d'où vient le problème
si quelqu'un aurait une idée ‼
voici le lien du fichier : GIotf0xcWb3_Moy-8h.xlsx
Merci pour vos réponses
Utile
+0
plus moins
Bonjour;

Le lien n'est pas valide !
sara-87 60Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 14 sept. 2017 à 22:34
Bonjour ,
voici un autre lien : http://www.cjoint.com/c/GIouGlNO6r3
Merci bcp !!
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous les deux

Pas tout compris,
En D10 essaies ceci pour un calcul s'il y a au moins 6 nombres dans la plage
=SI(NB(B3:B10)>=6;MOYENNE(B3:B10);"err")
ou bien ceci pour un calcul s'il y a au moins 6 nombres dans la plage supérieurs ou égaux à 6
=SI(NB.SI(B3:B10;">=" &6)>=6;MOYENNE(B3:B10);"err")
ou ceci pour un calcul, de la moyenne des nombres de la plage qui sont supérieurs ou égaux à 6
=SI(NB.SI(B3:B10;">=" & 6)>=6;SOMMEPROD((B3:B10>=6)*(B3:B10))/NB.SI(B3:B10;">="&6);"err")

Cdlmnt
Donnez votre avis
Utile
+0
plus moins
Bonjour

Essaie en mettant en C10 :
=SI(NB.SI(B3:B10;">0")>=6;1;0)
et en D10 :
=SI(C10=1;MOYENNE(;B3:B10);"")

Cdlmnt
Via
Donnez votre avis
Utile
+0
plus moins
Bonjour à vous tous.

En m'appuyant sur les propositions déjà faites, voici ma solution :
1) Insérer une ligne vide tout en haut (pour avoir 2 cellules B1 et B2 sans valeur numérique)
2) Laisser C3:C7 vides
3) En C8 saisir la formule =MOYENNE(B1:B8)
4) Recopier cette formule vers le bas.
Il ne peut pas y avoir plus simple !
Raymond PENTIER 43566Messages postés lundi 13 août 2007Date d'inscription ContributeurStatut 22 septembre 2017 Dernière intervention - 15 sept. 2017 à 13:43
C'est vraiment décourageant de chercher à aider, surtout dans le sens de la simplification !
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous,
en fait j'ai essayé la première formule proposée par ccm81 et ça a bien marché .
un grand merci à vous tous pour votre aide et bonne journée à tous
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !