Signaler

Afficher #N/A si résultat = 0 [Résolu]

Posez votre question CEMALOU2011 15Messages postés vendredi 8 septembre 2017Date d'inscription 9 septembre 2017 Dernière intervention - Dernière réponse le 9 sept. 2017 à 19:38 par CEMALOU2011
Bonjour,

J'ai actuellement la formule ci dessous :
=($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3

Je veux toutefois que si le résultat est = 0 alors qu'il m'affiche #N/A. J'ai essayé la formule ci dessous qui me renvoi 0 au lieu de #N/A.

=SIERREUR($EC$21*EF21+$EC$17*EF17+$EC$12*EF12;#N/A)/3
J'ai également essayé :
=SIERREUR($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3);#N/A)

Si vous pouvez m'aider je suis preneuse :)
Utile
+0
plus moins
Bonsoir

La formule avec SIERREUR ne détecte aucune erreur puisque le résultat 0 est une possibilité de calcul pas une erreur

Essaie plutôt =SI(($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3=0;"erreur";($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3)

Cdlmnt
Via

eriiic 21052Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 23 septembre 2017 Dernière intervention - 8 sept. 2017 à 18:25
voire même :
=SI(($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3=0;NA();($EC$21*EF21+$EC$17*EF17+$EC$12*EF12)/3)

;-)
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci de vos retours toujours aussi rapide et efficace !

Je ne sais pas comment je ferai sans votre support, merci encore

Mon problème est résolu grâce à vos conseils :)
CEMALOU2011 15Messages postés vendredi 8 septembre 2017Date d'inscription 9 septembre 2017 Dernière intervention - 9 sept. 2017 à 10:15
il me semble mais à l'évidence non

Idem avec : =SI(SOMMEPROD(EG13:EG16;$EC$13:$EC$16)=0;NA())
Idem avec : =SI(SOMMEPROD(EG13:EG16)=0;N/A();($EC$13:$EC$16))

:(
Répondre
eriiic 21052Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 23 septembre 2017 Dernière intervention - 9 sept. 2017 à 13:15
il me semble
tu plaisantes j'espère ?
=si(ta_formule=0;na();ta_formule)
Répondre
CEMALOU2011 15Messages postés vendredi 8 septembre 2017Date d'inscription 9 septembre 2017 Dernière intervention - 9 sept. 2017 à 15:59
Nous n'avons visiblement pas la même expertise dans ce domaine :)

En quoi cette formule ne fonctionne pas : =SI(SOMMEPROD(EE13:EE16;EC13:EC16=0;"NA"())/EE13:EE16) ??

Même si ceal te semble évident, cela ne l'est pas pour tous ;-)
Répondre
eriiic 21052Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 23 septembre 2017 Dernière intervention - 9 sept. 2017 à 18:20
Pas besoin d'être expert pour recopier un modèle, c'est un exercice qu'on fait faire aux enfants.
Elle ne fonctionne pas parce qu'elle ne veut rien dire comme te le dit excel.
Répondre
CEMALOU2011 15Messages postés vendredi 8 septembre 2017Date d'inscription 9 septembre 2017 Dernière intervention - 9 sept. 2017 à 19:38
merci de ton retour :) Cela m'aide moins que précédemment et je vais continuer à solliciter de l'aide.
Encore merci pour ta précieuse aide. Vous restez tous autant que vous êtes d'un support très apprécié.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !