Signaler

Rendre invisible une textbox à l'ouverture du classeur [Résolu]

Posez votre question Landry85 90Messages postés mardi 5 novembre 2013Date d'inscription 17 septembre 2017 Dernière intervention - Dernière réponse le 8 sept. 2017 à 16:00 par via55
Bonjour à tous,

J'essais de rendre invisibles mes textbox à l'ouverture de mon classeur mais mon code ne fonctionne pas, je l'ai placé dans ThisWorkbook :

Private Sub Workbook_Open()

  Application.OnKey "{ESCAPE}", "" ' touche Echap inactive
  Application.DisplayFullScreen = True ' affichage plein écran
  ActiveWindow.DisplayWorkbookTabs = False ' onglets masqués
  ActiveWindow.DisplayHorizontalScrollBar = False 'barre de défilement masquée
  ActiveWindow.DisplayVerticalScrollBar = False 'barre de défilement masquée
  CacheBOutils ' masque les barres d'outils
  ActiveWindow.Zoom = 100
  ActiveSheet.ScrollArea = "A1:O32"
  
     
  With Me.TextBox1.Visible = False
     Me.TextBox2.Visible = False
     Me.TextBox3.Visible = False
     Me.TextBox4.Visible = False
     Me.TextBox5.Visible = False
  End With
  
  With Worksheets("KiKiFé").Me.ComboBox2
  .Select
  .Activate
  End With

End Sub

Sub CacheBOutils()
  Dim CmdB As CommandBar
  For Each CmdB In Application.CommandBars
    CmdB.Enabled = False
  Next CmdB
End Sub


Ce n'est pas la bonne façon de l'écrire peut être?
Utile
+0
plus moins
Bonjour,

Apparemment c'est ton WITH qui est mal écrit, essaye ceci :
  With Me.
     TextBox1.Visible = False
     .TextBox2.Visible = False
     .TextBox3.Visible = False
     .TextBox4.Visible = False
     .TextBox5.Visible = False
  End With

Cdlmnt
Via
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !