Signaler

Pas de connexion Ethernet sous Linux

Posez votre question Samuel le DX 121Messages postés vendredi 3 janvier 2014Date d'inscription 13 septembre 2017 Dernière intervention - Dernière réponse le 14 sept. 2017 à 08:29 par Exileur
Bonsoir,

Je possède un PC fixe avec Linux Mint 17 et Windows 7 en dualboot. Sous windows Internet marche parfaitement, mais sous Linux non. Même en bootant sur des clés avec xbuntu, ubuntu et Mint 19 je n'ai pas internet. Je suis chez Free. Merci d'avance de votre aide.

Utile
+0
plus moins
Bonjour,

1) Pour mieux comprendre la cause du problème, peux-tu nous copier-coller le résultat des commandes suivantes (quitte à te connecter en wifi en attendant), à taper dans un terminal ?

lspci | grep -i ethernet
/sbin/ifconfig -a


2) Si dans la seconde commande, tu vois une carte qui s'appelle
eth0
(resp.
ensp0
) est-ce que la commande
sudo dhclient eth0
résout ton problème (resp.
sudo dhclient ensp0
) ?

3) Si ça ne marche pas à l'issue de cette commande, précise-nous dans quel contexte tu te connectes à internet (via une box ?) et le résultat des commandes suivantes :

/sbin/route -n
nslookup www.google.fr
ping -c2 www.google.fr


Bonne chance
Exileur 1127Messages postés mercredi 31 août 2011Date d'inscription 14 septembre 2017 Dernière intervention - 14 sept. 2017 à 08:29
Salut mamiemando,

Les commandes ifconfig et route sont dépréciées depuis déja quelques années (2009) ;))

Tu peux utiliser :

ip address
ip route

A plus
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour, voici les résultats
1) lspci | grep -i ethernet
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 0
2) /sbin/ifconfig -a
eth0 Link encap:Ethernet HWaddr d8:50:e6:3f:6c:88
inet6 addr: fe80::da50:e6ff:fe3f:6c88/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:81 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6349 (6.3 KB) TX bytes:8842 (8.8 KB)
Interrupt:20 Memory:ef200000-ef220000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:135 errors:0 dropped:0 overruns:0 frame:0
TX packets:135 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9637 (9.6 KB) TX bytes:9637 (9.6 KB)
3) sudo dhclient eth0
lspci | grep -i ethernet


Après cette commande, le réseau cablé s'est déconnecté puis est revenu à son état de tentative de connexion, puis se redeconnecte

Je me connecte à une Freebox.

4) /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
5) nslookup www.google.fr
;; connection timed out; no servers could be reached
6) ping -c2 www.google.fr
ping: unknown host www.google.fr


Je ne peux pas me connecter en Wifi avec ce PC.
Merci de votre aide.
Donnez votre avis
Utile
+0
plus moins
Ok donc la carte est détectée et s'appelle bien
eth0
. Par contre la connexion échoue ce qui est bizarre.

1) Commençons par voir si ça n'est pas matériel.

En espérant que le paquet
net-tools
soit installé, et ainsi que tu aies la commande
mii-tool
de disponible, que donne la commande :

sudo mii-tool eth0


Si tu as le message
eth0: no link
ou un message d'erreur suspect (reporte-le dans le doute) c'est peut-être ton câble ethernet qui est défectueux ou un port (de la freebox ou de la carte réseau). Je t'invite par la même occasion à tester :
- avec un autre port ethernet de freebox
- avec un autre câble ethernet

Si tu as moyen de tester ta carte ethernet chez un ami, cela pourrait également nous permettre de resserrer l'éventail des suspects.

2) Si ça ne résout pas le problème, c'est peut-être lié à PCI : voir message 17 dans ce fil de discussion

Bonne chance
Donnez votre avis
Utile
+0
plus moins
Bonsoir,

Désolé du délai de réponse. J'ai testé toute ces commandes. Le câble n'était pas défectueux.

J'ai voulu réinstaller Linux, sauf que mon Windows n'était plus présent dans grub. Du coup, j'ai remplacé Grub par le MBR de windows, et je ne peux donc plus accéder à mon Linux (j'avais besoin de windows pour travailler).

J'ai donc installé un Linux Mint 18.2 sous virtual box, et là, Internet fonctionne parfaitement. Je retenterai de remettre grub et de remettre Internet à mon Linux plus tard. La connexion internet marchait en USB lorsque je faisais un partage de connexion avec mon téléphone.

Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !