Signaler

Pourcentage d'avancement selon résultat [Résolu]

Posez votre question Loupiote3164 13Messages postés mercredi 6 septembre 2017Date d'inscription 22 septembre 2017 Dernière intervention - Dernière réponse le 6 sept. 2017 à 12:27 par Vaucluse
Bonjour,

Je suis actuellement en stage et l'on m'a demandé de faire le point sur la situation de l'entreprise par rapport à la nouvelle version de la norme ISO 14001.
Pour cela j'ai créé un fichier excel avec les différents points de la norme auxquels je donne une note comprise entre 1 et 5 (1 étant incomplet et 5 complet)

par exemple pour une exigence A j'ai 3 lignes correspondantes à 3 sous-parties.
Je souhaiterai donner un pourcentage d'avancement de cette exigence.
avec si somme des 3 sous-parties=15 car 3*5=15 alors 100%
si la somme est comprise entre 14 et 10 alors 66%
si la somme est comprise entre 9 et 5 alors 32%
si la somme est comprise entre 4 et 0 alors 0%

Est-ce que quelqu'un sait comment faire?
en vous remerciant

Utile
+0
plus moins
Bonjour

à adapter

vos notes en A2,A3,A4

en A5:

=SI(SOMME(A2:A4)<=4;0%;SI(SOMME(A2:A4)<=9;32%;SI(SOMME(A2:A4)<=14;66%;100%)))

crdlmnt
Loupiote3164 13Messages postés mercredi 6 septembre 2017Date d'inscription 22 septembre 2017 Dernière intervention - 6 sept. 2017 à 11:42
Merci ça marche.
J'avais déjà essayé si(somme...) mais j'avais du mal mettre les parenthèses
Cordialement
Répondre
Vaucluse 20348Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 22 septembre 2017 Dernière intervention - 6 sept. 2017 à 12:27
pas de quoi
je passe le sujet en résolu
vous pouvez aussi pur info et pour l'avenir, jeter un œil sur la proposition de notre ami ccm81 (salut) qui est une autre version de la mienne.
bonne route
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour

Ta somme en A2
formule en B2
=SI(A2=15;100%;SI(A2>=10;66%;SI(A2>=5;32%;0%)))

à toi de voir pour les >=

Cdlmnt
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !