Signaler

Machine virtuelle qui rame

Posez votre question charline159 65Messages postés lundi 14 août 2017Date d'inscription 28 octobre 2017 Dernière intervention - Dernière réponse le 1 sept. 2017 à 16:42 par charline159
Bonjour,

J'utilise Windows 7 et je fais souvent de la virtualisation avec Linux.

Quand je fais tourner la machine virtuelle, elle rame beaucoup (et ce, peu importe la distrib: Ubuntu, Tails, Gnome, Kali, Fedora, etc.). Ma souris n'est pas fluide, et quand je lance firefox par exemple, ce dernier met beaucoup de temps à s'ouvrir, etc.

Voilà mon configuration:
OS: Windows 7, 64 bits
CPU: i5 2500K, 3,30Ghz
Ram: 12 Go (4gox2 + 2gox2)

Et donc j'aurais bien aimé savoir pourquoi ça rame? J'aimerais que ma machine virtuelle soit aussi fluide que Windows! Devrais-je songer à changer/upgrader un de mes composants?

Cordialement
Utile
+0
plus moins
Bonjour,

Tu ne précises pas le logiciel utilisé pour la virtualisation, mais j'imagine qu'il s'agit de Virtualbox. Les additions-invités sont installés ? Autrement open-vm-tools pour VMWare

Quels ressources alloues-tu ? J'ai quelques serveurs et client de test en VM et tous tournes très bien avec 1 CPU et 1Go de RAM.
charline159 65Messages postés lundi 14 août 2017Date d'inscription 28 octobre 2017 Dernière intervention - 29 août 2017 à 16:09
Salut! En effet, j'utilise VirtualBox.
J'alloue 4096 Mio et 1 CPU à la machine virtuelle!
Je viens d'installer les additions-invités, mais je ne vois pas de différences.

Sinon quand j'alloue 2 CPU à la machine, je vois une nette différence... Le soucis c'est que je la démarre ensuite, elle affiche souvent :
L'instruction à 0xe59e6d43 emploie l'adresse mémoire 0x000000018. La mémoire ne peut pas être en état 'read'. Cliquez sur OK pour terminer le programme.


Et ensuite sur VirtualBox, il y a marqué "avortée" sur la machine virtuelle.
Répondre
Utilisateur anonyme - 29 août 2017 à 18:45
Pour l'erreur de machine avortée : sur ce forum (de nombreux autres rapportent ce soucis de 0x0[...]18) et il suggère de changer le contrôleur audio : "Disable audio in the VM config, or change it from AC97 to HD Audio."
Je ne vois pas trop le rapport, mais ça reste étrange que les VM soit aussi lentes.. Pas d'applications "superflus" lorsque tu utilises Virtualbox ?

Au besoin, tu peux utiliser l'utilitaire "msconfig" pour désactiver applications et services au démarrage (Démarrer -> Exécuter ou touche Win + R puis "msconfig").

Le(s) DD de l'hôte sont récents / en bon état ? Pas de cluster HS ou de latence particulière pour ouvrir des fichiers ou travailler sur ton PC en dehors de VB ?

Oui, je pars dans toutes les directions, mais on trouvera bien quelque chose :P
Répondre
charline159 65Messages postés lundi 14 août 2017Date d'inscription 28 octobre 2017 Dernière intervention - 1 sept. 2017 à 16:42
Que sont les "DD" ?
Sinon, en dehors de VirtualBox, il n'y a pas de problème; tout est fluide sur ma machine locale. Et je ne lance pas d'applications "lourdes" quand je lance VM!

Je vais changer mes paramètres du coup, merci pour ton aide!
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !