Signaler

Fonction SI à 2 ou 3 condition

Posez votre question Balzac - Dernière réponse le 14 août 2017 à 01:05 par marc
Bonjour,

Je recherche la fonction SI() permettent d'avoir 2 condition.

Si(A1>1 et A2>1 : OUI : NON)

Mais je n'arrive pas a formuler le ET

Ma base c'est sa. Mais dedant je n'ai qu'une condition j'en aimerais 3.

=SI(E6<100000;"Rien";SI(E6<200000;"Bronze";SI(E6<350000;"Argent";SI(E6<500000;"Or";SI(E6<650000;"Platine";SI(E6<850000;"Diamant";"Héro"))))))
Utile
+0
plus moins
Bonjour,

=Si(et(A1>1; A2>1) ; OUI ; NON)

C'est quoi le rapport avec "ta base" ?
Crdmt
Donnez votre avis
Utile
+0
plus moins
Bah c'est que j'ai plusieur catégorie dans ma base enfaite donc plus complexe quand ont veut 3 condition
Donnez votre avis
Utile
+0
plus moins
Bonsoir Balzac,

Pour ta longue formule, il faut inverser l'ordre des tests, comme ceci :

=SI(E6>=850000;"Héro";SI(E6>=650000;"Diamant";SI(E6>=500000;"Platine";SI(E6>=350000;"Or";SI(E6>=200000;"Argent";SI(E6>=100000;"Bronze";"Rien"))))))

Pour 3 conditions : =SI(ET(A1>1;A2>1;A3>1);"OUI";"NON")
Pour 2 conditions : =SI(ET(A1>1;A2>1);"OUI";"NON")

Cordialement
 
marc- 14 août 2017 à 01:05
 
Bonjour Balzac,

Suite au message de Djidji59430, je me suis rendu compte que je me suis "mélangé les pinceaux", pour ta longue formule de départ : elle était bonne
et c'est inutile d'inverser l'ordre des tests, désolé.

Ce que j'ai écris en dessous pour les formules courtes à 3 ou 2 conditions
reste valable ; mets bien "OUI" et "NON" (avec les guillemets).

Cordialement
 
Répondre
Donnez votre avis
Utile
+0
plus moins
Balzac a écrit:
Pour ta longue formule, il faut inverser l'ordre des tests

Pourquoi ???
marc- 14 août 2017 à 00:57
Bonjour DjiDji59430,
C'est moi, marc, qui ai écrit cela, pas Balzac ; mais tu as raison :
la longue formule de départ était bonne : c'est inutile d'inverser
l'ordre des tests ; je me suis "mélangé les pinceaux", désolé.
Cordialement
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !