Signaler

Asterisk 14

Posez votre question phenix2017 - Dernière réponse le 11 août 2017 à 10:31 par mamiemando
Bonjour

En installant asterisk 14 dans ubuntu 16.04 j'obtiens ce message

E: impossible de trouver le paquet lsqlite3


S'il vous plaît, pouvez-vous m'aider à régler ce problème? Merci.
Utile
+0
plus moins
Bonjour,

Explication du problème

Je pense que c'est parce que tu tentes d'installer asterisk autrement que via la logithèque ou une commande apt.

En l'occurrence le paquet
lsqlite3
s'appelle
libsqlite3-0
sous ubuntu.

Résolution du problème

Personnellement je te recommande d'installer asterisk plutôt par les paquets. Par défaut il n'apparaîtra pas dans la liste, car ce paquet est dans les dépôts universe comme le montre cette page :
https://packages.ubuntu.com/zesty/asterisk

Il faut donc au préalable activer les dépôts universe. Ceci revient à corriger
/etc/apt/sources.list
.

1) Commence par lire :
https://doc.ubuntu-fr.org/sources.list
https://doc.ubuntu-fr.org/depots#depots_officiels

2) Maintenant modifions ce fichier :

gksudo gedit /etc/apt/sources.list &


Ajoute dans ce fichier les lignes adéquates pour le dépôt universe, en remplaçant "xenial" par ta version d'ubuntu.

deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe multiverse
deb http://security.ubuntu.com/ubuntu xenial-security universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe multiverse


Sauve et quitte.

3) Réindexe les dépôts (
sudo apt-get update
adns un terminal, ou lance une mise à jour dans la logithèque)

4) Installe asterisk via ta logithèque (ou
sudo apt-get install asterisk
).

Bonne chance
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !