Signaler

Pourquoi cet algorithme est faux ? [Fermé]

Posez votre question theniet - Dernière réponse le 6 août 2017 à 09:00 par Whismeril
Bonjour, pour quoi
cet algo - palindrome est faux ?

algo mot_palindrome

variables n,x,y : entier
mot : chaine

debut
ecrire("entrer un mot : ")
lire(mot)
n:=len(mot) //longueur de mot
x:=0
y:=1
pour i=1 à n/2
si milieu(mot,i,1)=milieu(mot,n-i+1,1) alors
x:=1
sinon
y:=0
finsi
finpour

si y:=0 alors
ecrire("Bravo! ce mot est un palindrome")
sinon
ecrire("Désolé, ce mot n'est pas un palindrome")
finsi
fin





Utile
+0
plus moins
Bonsoir,

Merci d'utiliser les balises afin d'être lisible et de ne pas mettre votre pseudo comme titre.

variables n,x,y : entier 
mot : chaine 

debut 
ecrire("entrer un mot : ") 
lire(mot) 
n:=len(mot) //longueur de mot 
x:=0 
y:=1 
pour i=1 à n/2 
si milieu(mot,i,1)=milieu(mot,n-i+1,1) alors 
x:=1 
sinon 
y:=0 
finsi 
finpour 

si y:=0 alors 
ecrire("Bravo! ce mot est un palindrome") 
sinon 
ecrire("Désolé, ce mot n'est pas un palindrome") 
finsi 
fin 


Bav.
Utile
+0
plus moins
Bonjour

Doublon
http://www.commentcamarche.net/forum/affich-34758634-notation

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !