Somme de valeurs en fonction d'une autre colonne [Résolu]

minermine 26 Messages postés lundi 24 juin 2013Date d'inscription 6 août 2017 Dernière intervention - 5 août 2017 à 19:39 - Dernière réponse : minermine 26 Messages postés lundi 24 juin 2013Date d'inscription 6 août 2017 Dernière intervention
- 6 août 2017 à 08:42
Bonjour,

Je suis actuellement bloqué dans avec mon fichier excel.


Je suis en présence d'un tableau avec plusieurs colonnes ( uniquement deux me servent dans le cas présent ).

Je souhaiterais, avec une formule ( je souhaite éviter au maximum le VBA ), faire la somme des valeurs de la colonne B si les valeurs de la colonne A sont les même.

je ne pense pas être très clair donc voyez plutôt l'image ci-dessous :

je souhaite faire la somme des crédits si le mois correspond bien à ce que je veux.

Merci d'avance,
Romain

http://img-19.ccm2.net/AleHkDFlH-aERAtgNpY7T8cB7wI=/d7cb87bbf42e42f78f6970557cd5c36a/ccm-ugc/CCM.png
Afficher la suite 
26Messages postés lundi 24 juin 2013Date d'inscription 6 août 2017 Dernière intervention

3 réponses

Répondre au sujet
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - Modifié par Vaucluse le 5/08/2017 à 20:51
+1
Utile
1
Bonsoir

votre image n'est pas très claire, et vous parlez de colonnes A et B qui sont bien loin du champ de vision!!!!

pour le principe, faire la somme de la colonne B pour une colonne de dates en A selon le mois des lignes 2 à 100

trois options:

soit vous avez quelque part une cellule (mettons Z1) pour entre le N° du mois et alors:

=SOMMEPROD((MOIS($A$2:$A$100)=$Z$1)*($B$2:$B$100))

soit vous tirez la formule sur la hauteur pour avoir à chaque ligne le cumul du mois en A:

=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(A2))*($B$2:$B$100))

soit vous avez une somme évolutive selon le champ au dessus de la formule, (toujours en tirant et en commençant en A2):

=SOMMEPROD((MOIS($A$2:A2)=MOIS(A2))*($B$2:B2))


qui vous donnera la somme du mois en A depuis le début du champ jusqu'à la ligne de la formule

attention dans tous les cas aux signes $ aux bons endroits)
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Cette réponse vous a-t-elle aidé ?  
minermine 26 Messages postés lundi 24 juin 2013Date d'inscription 6 août 2017 Dernière intervention - 6 août 2017 à 08:42
Merci,

c'était bien la fonction sommeprod qui me fallait ici.
Commenter la réponse de Vaucluse
via55 8785 Messages postés mercredi 16 janvier 2013Date d'inscription 11 décembre 2017 Dernière intervention - 5 août 2017 à 19:54
0
Utile
Bonsoir

Si tu veux de l'aide c'est pas une image qu'il faut joindre mais un exemple de ton fichier, à poster sur cjoint.com, faire créer un lien, le copier et revenir la coller ici

Cdlmnt
Via
Commenter la réponse de via55