Signaler

Calcul de nombre de jour de dépassement d'une valeur [Résolu]

Posez votre question sara-87 60Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - Dernière réponse le 3 août 2017 à 19:00 par JvDo
Bonjour à tous,
Je cherche une fonction sur Excel qui permet de calculer le nombre de jours où la moyenne glissante sur 8 heures dépasse une valeur, sachant que mes données sont en valeurs horaires (document joint) http://www.cjoint.com/c/GHcmDdp4yDc.
J’ai essayai de passer par les filtres de valeur numériques et utiliser une formule simple pour effectuer le calcul, mais j’ai remarqué que parfois il y a plusieurs dépassement pendant le même jour et donc le même jour est compté plusieurs fois, ce qui entraîne un calcul totalement erroné.
Si quelqu’un sait comment s’y prendre pour résoudre ce problème j'en serais vraiment ravie !
Utile
+0
plus moins
Bonjour,

Ton lien ne fonctionne pas

Crdmt
JvDo 1774Messages postés mercredi 27 juillet 2005Date d'inscription 6 novembre 2017 Dernière intervention - 2 août 2017 à 18:02
Bonjour,

retire le point en fin d'url.

cordialement
Répondre
Vaucluse 20649Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 11 novembre 2017 Dernière intervention - 2 août 2017 à 18:20
Vi Jv, (salut vous!!)
c'est ce que j'ai fait, mais je tombe sur un fichier format je ne sais quoi que je ne peux pas ouvrir
Tu peux toi?
crdlmnt
Répondre
DjiDji59430 1724Messages postés samedi 19 avril 2008Date d'inscription 13 novembre 2017 Dernière intervention - 2 août 2017 à 18:33
Bonjour,

C'est un fichier.rar parce que l'original fait 30 mégas et que cjoint est limité a 15 megas.
Régulierement, avec un OS "moderne", un double clic le decompresse !

Crdmt
Répondre
Vaucluse 20649Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 11 novembre 2017 Dernière intervention - 2 août 2017 à 19:33
Alors chez moi ça doit être un OS vieux "nonos"! (ou alors c'est moi le pauvre vieux dans cette histoire!)
Mais dans ce cas, pourquoi pas utiliser celui ci:
https://mon-partage.fr/
(jusqu'à 200Mo)
...quoique un excel de 30 mo sur mon Acer (à rien), ça n'est pas gagné :-))

bonne soirée
Répondre
JvDo 1774Messages postés mercredi 27 juillet 2005Date d'inscription 6 novembre 2017 Dernière intervention - 2 août 2017 à 19:52
Bonsoir,

surtout que les lignes 1097 à 1 040 000 ne servent à rien.
en les supprimant, tu repasses sous les 3mo.

sinon une formule matricielle qui fait presque le job :
en B4,
=SOMMEPROD(--(PRODUITMAT((TRANSPOSE(LIGNE(INDIRECT("1:1092")))>3*(LIGNE(INDIRECT("1:364"))-1))*(TRANSPOSE(LIGNE(INDIRECT("1:1092")))<=3*LIGNE(INDIRECT("1:364")));SIERREUR(--('Moy 8 hs'!C$4:C$1095>110);0))>0))


quand je dis que ça fait presque le job c'est que je ne gère que les journées avec 3 moyennes de 8 heures.
il faut donc gérer le rompu du début et celui de fin, juste au cas où il y aurait des données >110.

cordialement

PS : 1092=3*364. il faudra donc adapter au nombre réel de jours complets
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonsoir,

maintenant, une formule matricielle complète, en B4 toujours :
=SOMMEPROD(--(PRODUITMAT(--(TRANSPOSE(ENT('Moy 8 hs'!$A$2:$A$1096))=LIGNE(INDIRECT(MIN(ENT('Moy 8 hs'!$A$2:$A$1096))&":"&MAX(ENT('Moy 8 hs'!$A$2:$A$1096)))));SIERREUR(--('Moy 8 hs'!C$2:C$1096>110);0))>0))


cordialement

re PS : une explication sur la matrice gauche :
sara-87 60Messages postés mardi 2 avril 2013Date d'inscription 15 septembre 2017 Dernière intervention - 3 août 2017 à 18:44
Bonjour,
Merci beaucoup pour votre effort mais j'ai encore un soucis ,j'ai appliqué votre formule sur des données mais le calcul ne donne que des "zéro" ;ce qui veut dire que la valeur 110 n'a pas été dépassée alors que j'ai plusieurs jours ou elle l'est.
pourriez vous revoir cela et essayer de me le corriger parce que je n'y pige rien ;)
cordialement
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Juste au cas où tu ne saurais pas ce qu'est une formule matricielle, n'oublie pas de valider les formules par CTRL+SHIFT+ENTER.

Si ça ne fonctionne toujours pas, il faudra remettre ton fichier en ligne.

Cordialement
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !