Fichiers .htaccess ne fonctionnent pas ?

rcsofficiel 1 Messages postés mardi 1 août 2017Date d'inscription 1 août 2017 Dernière intervention - 1 août 2017 à 20:00 - Dernière réponse : avion-f16 18236 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 15 septembre 2017 Dernière intervention
- 12 août 2017 à 00:55
Bonjour,

J'ai récemment tenté d'activer le mode Rewrite sur mon VPS, hors celui-ci ne semble pas du tout fonctionner.
Contexte: J'ai un VPS qui tourne sous Debian 8 avec Apache2. (Mis à jour) Le fichier de configuration de mon site par défaut est: 000-default.conf
Voici le contenu du fichier .htaccess:
#	Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
AllowOverride All
RewriteEngine On
# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>

Le DocumentRoot est var/www/html et voici le fichier par défaut (000-default.conf):
<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

ServerAdmin webmaster@localhost
DocumentRoot /var/www/html

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf

<Directory "/var/www/html">
Options Indexes FollowSymLinks
AllowOverride All
Allow from All
</Directory>


</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Afficher la suite 
1Messages postés mardi 1 août 2017Date d'inscription 1 août 2017 Dernière intervention

2 réponses

Répondre au sujet
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 7 août 2017 à 10:15
0
Utile
Bonjour,

Quitte à repartir sur un nouveau vhost, essaye de suivre cette méthodologie.

Puis modifie progressivement ce nouveau vhost (en testant régulièrement et en pensant bien à relancer apache à chaque test) pour aller progressivement vers ton vhost actuel.

Bonne chance
Commenter la réponse de mamiemando
avion-f16 18236 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 15 septembre 2017 Dernière intervention - 12 août 2017 à 00:55
0
Utile
Bonjour,

La directive AllowOverride ne peut pas se trouver dans le .htaccess.

Ton site se trouve-t-il bien dans /var/www/html et pas dans un sous-dossier comme /var/www/html/xenforo/ ?
Commenter la réponse de avion-f16