Formule "si" cellule contient tel ou tel texte [Résolu]

Tonio5933 4 Messages postés jeudi 27 juillet 2017Date d'inscription 19 septembre 2017 Dernière intervention - 27 juil. 2017 à 18:57 - Dernière réponse : Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention
- 27 juil. 2017 à 20:10
Bonjour à toutes et tous,

Je galère depuis plusieurs jours et n'ai trouvé aucune réponse sur les forums.

Voilà le problème:
J'ai en colonne A du texte (par exemple NOM PRENOM)
Je voudrais en colonne B mettre une formule qui me donne un résultat en fonction d'une partie du texte de A.
Exemple: si A1 contient "Fabien" ou "Franck" ou encore d'autres prénoms (environ 10 possibilités), alors ça me renvoie "élève", autrement, rien.

Suis-je assez clair pour que quelqu'un puisse m'aider ?

Merci d'avance pour vos tuyaux





Afficher la suite 
4Messages postés jeudi 27 juillet 2017Date d'inscription 19 septembre 2017 Dernière intervention

4 réponses

Répondre au sujet
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention - Modifié par Mike-31 le 27/07/2017 à 19:06
+3
Utile
2
Bonsoir,

Une formule parmi d'autres

=SI(OU(NB.SI(A2;"*franck*");NB.SI(A2;"*michel*");NB.SI(A2;"*fabien*"));"élève";"")

à toi d'ajouter des NB.SI(A2;"*franck*") sans oublier les étoiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Cette réponse vous a-t-elle aidé ?  
Tonio5933 4 Messages postés jeudi 27 juillet 2017Date d'inscription 19 septembre 2017 Dernière intervention - 27 juil. 2017 à 19:53
Merci Mike !
Je viens de tester, et visiblement ça fonctionne.
Je termine ma formule avec tout ce dont j'ai besoin et reviens vers vous si je retombe en panne !

Encore merci
Mike-31 15889 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 décembre 2017 Dernière intervention > Tonio5933 4 Messages postés jeudi 27 juillet 2017Date d'inscription 19 septembre 2017 Dernière intervention - 27 juil. 2017 à 20:10
Re,

Ok pas de problème, de toute façon si ton problème est résolu n'oublie pas de mettre le statut de la discussion en résolu.
Cordialement
Commenter la réponse de Mike-31
DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention - 27 juil. 2017 à 19:09
0
Utile
Bonjour,

Quelle est la forme exacte de ton texte ? valable pour toute la colonne nom/prenom ?
Et tu ne peux pas dissocier le nom du prénom en 2 colonnes ??

Bonjour ,

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants.

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
Commenter la réponse de DjiDji59430