Accès au BIOS perdu [Résolu]

Rohjai 2 Messages postés dimanche 23 juillet 2017Date d'inscription 28 juillet 2017 Dernière intervention - 23 juil. 2017 à 18:13 - Dernière réponse : mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention
- 31 juil. 2017 à 10:11
Bonjour,

Ca fait pas mal de temps que Ubuntu est installé en dual boot avec windows sur ma machine. Cependant voilà: j'ai voulu accelerer le démarrage du PC en modifiant une option du BIOS. J'ai donc modifié l'option "vitesse de démarrage" en passant de normal à ultra rapide.
Résultat: le clavier n'est plus alimenté au démarrage. Donc impossible d'avoir de nouveau accès au bios grâce au clavier. Accès quasiment instantané au GRUB... mais impossibilité de faire le choix du système d'exploitation car le clavier ne s'alimente pas avant le démarrage de ce dernier.
Ironie du sort: je suis obligé d'attendre que le GRUB fasse le choix du système par défaut après 15s d'attente... c'est raté pour un démarrage rapide.

Une idée pour avoir de nouveau accès au BIOS ?

NB: j'en vois une: débrancher mon SSD où sont les systèmes et forcer le bios à se lancer. Mais j'aimerais savoir s'il existe une solution simple qui ne nécessite pas de démonter la tour.

Merci d'avance.

Rohjai.
Afficher la suite 
2Messages postés dimanche 23 juillet 2017Date d'inscription 28 juillet 2017 Dernière intervention

4 réponses

Répondre au sujet
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - Modifié par mamiemando le 24/07/2017 à 10:31
+1
Utile
Bonjour,

1) Avec windows

Il y a une option pour redémarrer dans le bios. Je me souviens l'avoir fait sous windows 8 comme ceci :
https://itsfoss.com/disable-uefi-secure-boot-in-windows-8/

D'autres idées :
https://www.asus.com/fr/support/faq/1013015/
http://packard-bell-fr.custhelp.com/app/answers/detail/a_id/28049/~/acc%C3%A9der-%C3%A0-la-configuration-%28bios%29-uefi-sur-un-syst%C3%A8me-windows-8

2) Avec linux

Tu peux essayer ceci (en root ou avec
sudo
) :
https://superuser.com/questions/519718/linux-on-uefi-how-to-reboot-to-the-uefi-setup-screen-like-windows-8-can

systemctl reboot --firmware-setup


3) En cas de désespoir

Autre approche, il y a surement moyen de revenir aux paramètres par défaut du BIOS, peut être en désalimentant ton PC et en retirant la pile.

Bonne chance
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de mamiemando
+1
Utile
Sa!ut,

Autre moyen : depuis ton linux, tu renommes le fichier /etc/grub.d/30_os-prober en 07_os-prober.

Tu actualises grub par sudo update-grub. Tu redémarres, et c'est Windows qui va se lancer automatiquement en priorité dans GRUB.

La, tu appliiques le premier lien de la réponse précédente, step 4, que tu peux obtenir directement par la commande shutdown /o /r /t 00

Tu dois alors accéder à l'uefi.
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Marcello
Rohjai 2 Messages postés dimanche 23 juillet 2017Date d'inscription 28 juillet 2017 Dernière intervention - 28 juil. 2017 à 15:30
0
Utile
1
Bonj0ur,

@mamiemando et Marcello: merci pour votre réponse de qualité. J'ai utilisé vos deux post pour résoudre mon problème:
1)J'ai renommé le fichier 30_os-prober et 07_os-prober puis actualisation du grub par sudo uptdate-grub dans linux.
2)Redémarrage: windows est bien passé en premier dans le grub.
3)Lien fourni par mamiemando pour me renseigner + commande shutdown /o /r /t 00 dans windows.
4)Redémarrage: accès au BIOS.
5)Désactivation de l'option ultra fast boot.
=>PROBLEME RESOLU !
Le tout a pris 5min.

Merci !
mamiemando 28084 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 9 décembre 2017 Dernière intervention - 31 juil. 2017 à 10:11
Félicitations et merci pour ton retour :-)
Commenter la réponse de Rohjai