Modifier les couleurs du terminal [Résolu]

artemis0 836 Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention - 23 juil. 2017 à 15:22 - Dernière réponse : artemis0 836 Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention
- 23 juil. 2017 à 17:35
bonjour,
comment activer les couleurs du terminal quand je suis en sudo ?
pi@raspberrypi:~ $ sudo -s
root@raspberrypi:/home/pi#

quand je fais un ls en root = pas de couleurs
et en pas root = couleurs

gras = en couleur

merci
Afficher la suite 
836Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention

4 réponses

Répondre au sujet
zipe31 35174 Messages postés dimanche 7 novembre 2010Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 23 juil. 2017 à 15:57
0
Utile
3
Salut,

1 - Utiliser
sudo -i
à la place de
sudo -s
.
2 - Une fois loguer en root (
sudo -i
), éditer le .bashrc et rajouter à la fin
alias ls='ls --color'

3 - Se déconnecter de root (CTRL+D)
4 - Se reconnecter
5 - Tester avec
ls -a

artemis0 836 Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention - 23 juil. 2017 à 16:52
salut,

merci de ton aide. j'ai fait exactement ce que tu as dit et ça ne fonctionne pas...
quand je fais un ls, que ce soit en sudo -i ou -s, les noms des fichiers et dossiers ne s'affichent pas en couleur. même après un reboot...
zipe31 35174 Messages postés dimanche 7 novembre 2010Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention > artemis0 836 Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention - 23 juil. 2017 à 17:29
As-tu édité le bon fichier .bashrc ?

Avec
sudo -s
tu passes root mais tu restes dans le répertoire de l'utilisateur.
Avec
sudo -i
tu passes root mais tu es dans le répertoire de root (/root) où se trouve le fichier .bashrc à éditer.
artemis0 836 Messages postés vendredi 3 janvier 2014Date d'inscription 11 décembre 2017 Dernière intervention - 23 juil. 2017 à 17:35
ah ok. j'avais édité celui qui se trouve dans /home/pi.
maintenant ça fonctionne.
merci beaucoup
Commenter la réponse de zipe31