Signaler

Modifier les couleurs du terminal [Résolu]

Posez votre question artemis0 829Messages postés vendredi 3 janvier 2014Date d'inscription 6 octobre 2017 Dernière intervention - Dernière réponse le 23 juil. 2017 à 17:35 par artemis0
bonjour,
comment activer les couleurs du terminal quand je suis en sudo ?
pi@raspberrypi:~ $ sudo -s
root@raspberrypi:/home/pi#

quand je fais un ls en root = pas de couleurs
et en pas root = couleurs

gras = en couleur

merci
Utile
+0
plus moins
Salut,

1 - Utiliser
sudo -i
à la place de
sudo -s
.
2 - Une fois loguer en root (
sudo -i
), éditer le .bashrc et rajouter à la fin
alias ls='ls --color'

3 - Se déconnecter de root (CTRL+D)
4 - Se reconnecter
5 - Tester avec
ls -a

artemis0 829Messages postés vendredi 3 janvier 2014Date d'inscription 6 octobre 2017 Dernière intervention - 23 juil. 2017 à 16:52
salut,

merci de ton aide. j'ai fait exactement ce que tu as dit et ça ne fonctionne pas...
quand je fais un ls, que ce soit en sudo -i ou -s, les noms des fichiers et dossiers ne s'affichent pas en couleur. même après un reboot...
Répondre
zipe31 35054Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 16 octobre 2017 Dernière intervention - 23 juil. 2017 à 17:29
As-tu édité le bon fichier .bashrc ?

Avec
sudo -s
tu passes root mais tu restes dans le répertoire de l'utilisateur.
Avec
sudo -i
tu passes root mais tu es dans le répertoire de root (/root) où se trouve le fichier .bashrc à éditer.
Répondre
artemis0 829Messages postés vendredi 3 janvier 2014Date d'inscription 6 octobre 2017 Dernière intervention - 23 juil. 2017 à 17:35
ah ok. j'avais édité celui qui se trouve dans /home/pi.
maintenant ça fonctionne.
merci beaucoup
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !