Signaler

Test cellule vide [Résolu]

Posez votre question Cédric - Dernière réponse le 18 juil. 2017 à 09:34 par Cédric
Bonjour,

Je cherche a vérifié si mes cellules sont bien rempli ou pas.
J'ai donc 2 colonnes (A et B avec des noms sur a peu près 100 lignes)
Mon test se trouve a coté de chacune de ces lignes et doit m'afficher 1 si l'une des deux cellules en A ou en B de la ligne n'est pas rempli et 0 si tout est rempli.
Si aucune valeur n'est rempli, il ne se passe rien.
J'ai utilisé la mise en forme conditionnelle pour afficher les couleurs (rouge si 1, vert si 0 et blanc si cellule vide), ça fonctionne.

Mon test ci dessosu m'affiche "#NOM?" mais je ne trouve pas mon erreur...

=SI(OU(ET(B2=ESTVIDE;A2<>ESTVIDE);ET(A2=ESTVIDE;B2<>ESTVIDE));1;0)


Quelqu'un pourrait-il me dire où est mon erreur afin de m'aider ?

merci beaucoup

Cédric
Afficher la suite 
Utile
+1
plus moins
Bonjour,
dans votre formule ESTVIDE est utilisé comme un nom et non comme fonction.
Quand vous écrivez B2 = ESTVIDE, c'est en vrai ESTVIDE(B2) = VRAI.
Donnez votre avis
Utile
+1
plus moins
Bonjour
et si on essayait:

=SI(NB.SI(A2:B2;"")=2;0;1)

ou même:

=NB.SI(A2:B2;"")

qui renvoie 0 si A et B vide; 1 si une des deux est remplie, et 2 s'elles le sont les deux

quant à la MFC formatez pour le 1 et le 0 le 2 s'il en est un, restera bien tout seul!
?

crdlmnt

Donnez votre avis
Utile
+0
plus moins
Bonjour,

Essayer avec cette formule:

=si(ET(A2="";B2="");"";SI(OU(A2="";B2="");1;0))
Donnez votre avis
Utile
+0
plus moins
Merci beaucoup :D
eriiic 20678Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 24 juillet 2017 Dernière intervention - 17 juil. 2017 à 15:48
Bonjour,
je met en résolu pour toi (en haut vers ton titre, pour la prochaine fois)
eric
Répondre
Cédric- 17 juil. 2017 à 16:03
Oui merci :) (j'ai pas trop l'habitude de comment ça fonctionne, ce n'est que la deuxième fois que je demande de l'aide comme ça, je trouve ça très sympa)

Sinon, la formule marche maintenant :
=SI(OU(ET(ESTVIDE(B2)=VRAI;ESTVIDE(A2)=FAUX);ET(ESTVIDE(A2)=VRAI;ESTVIDE(B2)=FAUX));1;0)


mais en fait je viens de me rendre compte qu'elle ne donne pas de résultat pour si mes cellules en A et en B sont toutes les deux vides car de ce fait je veux qu'il n'y ai pas de couleur qui s'affiche avec la mise en forme conditionnelle... (ex : 1 = rouge, 0 = vert et 2 = pas de couleur)
n'étant que novice encore sur excel je me suis perdu dans ma formule et je ne sais pas comment rajouter, dans la formule pour ESTVIDE(A2)=VRAI et ESTVIDE(B2)=VRAI...

Une idée ? :)
Répondre
Donnez votre avis
Utile
+0
plus moins
On va reprendre votre formule,

Si(ET(ESTVIDE(A2);ESTVIDE(B2));"";SI(OU(ET(ESTVIDE(A2)=VRAI;ESTVIDE(B2)=FAUX);ET(ESTVIDE(A2)=FAUX;ESTVIDE(B2)=VRAI));1;0))

Essayez avec cella la... et tenez nous au courant.
Cédric- 18 juil. 2017 à 09:34
Bonjour,

en effet votre formule fonctionne :)

merci de votre aide
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !