Signaler

Compter les doublons en fonction d'un critères [Résolu]

Posez votre question Serocelot - Dernière réponse le 17 juil. 2017 à 16:36 par Serocelot
Bonjour,

Après moult recherches et pas mal d'essai, je ne trouve toujours pas de réponses à ma question...

J'ai un tableau comprenant
Colonne A Colonne B Colonne C
Livreur Client Types de livraison

AG DUPONT TV
FD LENOIR AUDIO
GF DUPONT TV
YT MOUTARDE AUDIO
AG DUPONT CAMERA

Je voudrais trouver une formule qui me permette de savoir que j'ai eu
1 TV (parce que même client)
2 AUDIO
1 CAMERA

Il faudrait que lorsque j'ai le même client avec les deux mêmes types de livraisons, on ne prenne en compte qu'une seule fois le client.

Merci beaucoup beaucoup de votre aide
Afficher la suite 
Utile
+0
plus moins
Bonjour,

En D2 :
=NB.SI.ENS($B$2:$B$6;$B2;$C$2:$C$6;$C2)
à tirer jusqu'en D6
Serocelot- 17 juil. 2017 à 15:22
Merci beaucoup pour votre aide mais il me faudrait directement le total !
Je vous mets le lien vers un fichier construit de la même façon, cela certainement plus clair !
http://www.cjoint.com/c/GGrnvMGXIx5
Répondre
via55 7891Messages postés mercredi 16 janvier 2013Date d'inscription 20 juillet 2017 Dernière intervention - 17 juil. 2017 à 15:53
Re,

Ton fichier avec la formule matricielle en colonne L :
http://www.cjoint.com/c/GGrn0ni3gB6

Cdlmnt
Via
Répondre
Serocelot- 17 juil. 2017 à 16:36
Merci beaucoup !
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

Ce serait plutôt, avec en E2,E3 et E4 les valeurs TV,AUDIO et CAMERA, en F2 la formule matricielle (à valider par CTRL+Maj+Entrée) :
=NB(1/FREQUENCE(SI(($C$2:$C$7=E2);EQUIV($A$2:$A$7;$A$2:$A$7;0));LIGNE(INDIRECT("1:"&LIGNES($A$2:$A$7)))))
A étirer ensuite vers le bas

Cdlmnt
Via

Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !