Signaler

Besoin d'aide : EXcel

Posez votre question Faf - Dernière réponse le 17 juil. 2017 à 17:17 par Fafdukmer
Bonjour,

j'ai été satisfait de la solution la dernière fois.

aujourd'hui je reviens avec un autre problème. je voudrais programmer une colonne durée de vie qui serait égale à : Date de résolution-Date d'ouverture, mais le problème c'est que j'aimerais exclure de cette durée le délai d'attente, les jours non ouvrés comme le samedi et le dimanche, et même en ce qui concerne les jours ouvrés (lundi à vendredi), je veux exclure la plage horaire non ouvrée (18h à 8h du lendemain matin.)

que faire svp...

Cordialement

Utile
+0
plus moins
Bonjour

1° Sur une colonne de la feuille ou d'une autre feuille faire la liste des jours fériés (qui sont à exclure aussi) - sélectionner cette plage et la nommer feries

2° en supposant la date et l'heure d'ouverture en A2, la date et l'heure de résolution en B2, en C2 mettre la formule :
=(NB.JOURS.OUVRES(A2;B2;feries)-2)*10/24+(18-(HEURE(A2)+MINUTE(A2)/60))/24+(HEURE(B2)-8)/24

3° mettre C2 au Format personnalisé [h]:mm pour afficher un délai supérieur à 24 h

Cdlmnt
Via
PHILOU10120 4571Messages postés lundi 16 avril 2012Date d'inscription 22 septembre 2017 Dernière intervention - 17 juil. 2017 à 12:10
Il faut juste définir le nom de la plage dans le gestionnaire de nom, puis utiliser ce nom dans la formule

=SI(OU(B2="";C2="");"";(NB.JOURS.OUVRES('glpi (7)'!$B2;'glpi (7)'!$C2;fériés)-2)*10/24+(18-(HEURE('glpi (7)'!$B2)+MINUTE('glpi (7)'!$B2)/60))/24+(HEURE('glpi (7)'!$C2-8)/24))
Répondre
Fafdukmer 4Messages postés lundi 17 juillet 2017Date d'inscription 17 juillet 2017 Dernière intervention - 17 juil. 2017 à 16:06
Merci beaucoup PHILOU, ca marche et je commence à comprendre. mais il ya toujours quelques zones d'ombre que j'aimerais bien clarifier, comme la signification de certains nombres utilisés dans la formule...

Bon je la recopie et je les mets en gras pour que tu me dises ce que chacun d'eux représente stp.

=SI(OU(B2="";C2="");"";(NB.JOURS.OUVRES('glpi (7)'!$B2;'glpi (7)'!$C2;fériés)-2)*10/24+(18-(HEURE('glpi (7)'!$B2)+MINUTE('glpi (7)'!$B2)/60))/24+(HEURE('glpi (7)'!$C2-8)/24))

Merci d'avance!
Répondre
PHILOU10120 4571Messages postés lundi 16 avril 2012Date d'inscription 22 septembre 2017 Dernière intervention - 17 juil. 2017 à 16:37
18 et 8 heures de début et de fin
-2 jour de début et jour de fin vu qu'elles sont dans les heures de début et fin
Je pense que c'est ça la formule étant de VIA55
Répondre
via55 8276Messages postés mercredi 16 janvier 2013Date d'inscription 22 septembre 2017 Dernière intervention - 17 juil. 2017 à 16:44
Bonjour PHILOU ;-), bonjour Fafdukmer

Oui c'est exactement ça
NB.JOURS.OUVRES compte les jours ouvrés entre les 2 dates y compris celui du début et celui de la fin mais comme ceux ci ne sont pas complets à priori il faut les exclure et compter à part le temps pur ces 2 jours d'où les + en faisant la différence avec 18h ou 8h
Répondre
Fafdukmer 4Messages postés lundi 17 juillet 2017Date d'inscription 17 juillet 2017 Dernière intervention - 17 juil. 2017 à 17:17
Bonjour

un très grand merci à vous... cette solution m'aide beaucoup, je pense revenir vers vous au plus vite pour d'autres préoccupations

Cordialement!
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour Faf

Le fichier avec la formule de Via55 (que je salue)
Plus la liste Jour fériés que vous n'aviez pas créé
Regarder si cela vous convient ?

http://www.cjoint.com/c/GGqiUWMHyyx

Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !