Si ma recherchev est vide - mettre une autre recherchev [Résolu]

Claire - 14 juil. 2017 à 08:02 - Dernière réponse : gbinforme 14547 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention
- 14 juil. 2017 à 09:41
Bonjour,

Je cherche à savoir comment faire pour que quand ma recherchev = une cellule vide que ça me prenne une autre recherchev, mais que si ma 1ère recherchev est remplie qu'elle soit prise en compte.

J'ai tenté cette formule mais sans succès:

=SI(ESTVIDE(RECHERCHEV($A$11;Tableau2#Tout;4;FAUX));"SO";RECHERCHEV($A$11;Tableau2#Tout;6;FAUX))

Merci d'avance...
Claire


Afficher la suite 

7 réponses

Répondre au sujet
helma91 51 Messages postés dimanche 19 avril 2015Date d'inscription 14 juillet 2017 Dernière intervention - 14 juil. 2017 à 08:11
0
Utile
Salut, pas sûr d'avoir tout compris mais essaie ça:

=SI(A11="SO";RECHERCHEV(tableau2;6;FAUX);RECHERCHEV(A11;tableau2;4;FAUX))

Salutations
Commenter la réponse de helma91
0
Utile
1
Alors ça ne marche pas.

En fait c'est pas si A11 est vide que j'aimerais une autre recherchev, c'est quand ma 1èere recherche est vide que j'aimerais la 2ième.
Ma recherchev prendra toujours en compte la cellule A11 au départ.
helma91 51 Messages postés dimanche 19 avril 2015Date d'inscription 14 juillet 2017 Dernière intervention - 14 juil. 2017 à 08:47
Alors écoute, n'ayant pas le fichier je ne suis pas sûr de mon coup mais essaie quelque chose du genre. Sinon, tu peux essayer de faire une étape de plus dans ton calcul qui te facilitera la tâche.

Essaie quand même.

=SI((RECHERCHEV($A$11;Tableau2;6;FAUX))="";RECHERCHEV($A$11;Tableau2;4;FAUX);RECHERCHEV($A$11;Tableau2;6;FAUX))

Cordialement.
Commenter la réponse de Claire
gbinforme 14547 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 14 juil. 2017 à 09:01
0
Utile
Bonjour,

Tout simplement
=SI(RECHERCHEV($A$11;Tableau2;4;FAUX)=0;RECHERCHEV($A$11;Tableau2;6;FAUX);RECHERCHEV($A$11;Tableau2;4;FAUX))
Commenter la réponse de gbinforme
0
Utile
Merci beaucoup gbinforme, ça marche super bien!!!

Tout simplement comme tu dis ;-)

Bonne journée!!
Commenter la réponse de Claire
0
Utile
1
Encore juste une question:

Si ma 1ère recherchev est vide j'aimerais que la 2ième soit indiquée, mais si la deuxième est aussi vide, j'aimerais que la 3ième soit indiquée...

C'est possible??
Merci d'avance!
gbinforme 14547 Messages postés lundi 18 octobre 2004Date d'inscriptionContributeurStatut 17 janvier 2018 Dernière intervention - 14 juil. 2017 à 09:41
Re:
Cela se complique un peu mais il suffit de continuer le principe :
=SI(RECHERCHEV($A$11;Tableau2;4;FAUX)=0;SI(RECHERCHEV($A$11;Tableau2;6;FAUX)=0;RECHERCHEV($A$11;Tableau2;8;FAUX);RECHERCHEV($A$11;Tableau2;6;FAUX));RECHERCHEV($A$11;Tableau2;4;FAUX))

Ainsi tu as la colonne 4 ou 6 ou 8
Commenter la réponse de Claire