Signaler

Deux conditions SI avec texte dans deux cellules [Résolu]

Posez votre question TitiSavoie 4Messages postés lundi 10 juillet 2017Date d'inscription 10 juillet 2017 Dernière intervention - Dernière réponse le 10 juil. 2017 à 12:35 par via55
Bonjour,
Si je tape du texte en A1 (reconnaissance des voyelles), la cellule C1, affiche : "En cours".
Si je ne tape pas de texte en A1, rien ne s'affiche en C1.
Si le texte entraîne une décision spéciale, je veux taper "décidé" en B1.
En revanche, la décision ne peut pas être à la fois "décidé" et "en cours". Donc si je tape "décidé" en B1, je veux que le "en cours" de A3, disparaissent.

Ma formule la mieux est celle-ci, mais, elle ne fonctionne pas !!?
=SI(OU(ESTNUM(CHERCHE({"a";"e";"i";"o";"u"};A1)));"En cours";""); SI(B1="Décidé"; "")

En vous remerciant beaucoup de votre formule.




Afficher la suite 
Utile
+0
plus moins
Salut,

Avant-propos :
J'ai realise cette recherche sous un environnement en Anglais. Les traductions des formules ou les differences de synthaxe sont a prendre en compte dans la validite de cette reponse.

Voici la formule que j'ai etablis :
=SI(OU(ET(MAX(SI(ESTERREUR(CHERCHE({"a";"e";"i";"o";"u"},A1)),-1,1))=1,NON(B1="Decide")),ET(NON(MAX(SI(ESTERREUR(CHERCHE({"a";"e";"i";"o";"u"},A1)),-1,1))=1),B1="Decide")),"En cours","")

Sources :
XOR (OU exclusif)
Formule pour detecter voyelles inspire de cet article

Explications :
Ta formule est incorrecte pour plusieurs points :
1. Elle contient des points virgules pour separateur d'argument alors qu'il faut des virgules.
2. Quelques problemes avec tes parentheses.

Que fais ma formule ?
=SI(XOR(A1 contient une voyelle, B1 = "Decide"), "En cours", "")

Donnez votre avis
Utile
+0
plus moins
Merci bien pour cette réponse rapide. Cependant les deux formules sont refusées par Excel et je ne peux même pas les adapter !!
Je reformule ma demande si tu trouves cela plus clair grâce à ces exemples.

Si je tape en A1 "la fenêtre sera changée" dans la cellule A3, apparait "En cours".
Si je tape en A1 "la fenêtre sera changée vendredi" dans la cellule A3, apparait toujours "En cours" mais comme en A2 j'écris "décidé", je veux que le "En cours" de A3 disparaisse et donc que A3 soit vide.
Merci, merci -:)
Help-Jason 1325Messages postés mardi 28 juin 2011Date d'inscription 21 juillet 2017 Dernière intervention - 10 juil. 2017 à 11:25
J'a bien compris ta demande. La formule fonctionne chez moi mais en Anglais ... Pourrais-tu me donner l'etape a laquelle la formule plante ?

Tu peux me donner cette information en cliquant sur Evaluation de formule puis me donner le contenu sousligne
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour

Essaie ceci :
=SI(B1="Décidé";"";SI(SOMMEPROD((NBCAR(A1)-NBCAR(SUBSTITUE(A1;{"a"."e"."i"."o"."u"};""))))>0;"En cours";""))

Cdlmnt
Via
Help-Jason 1325Messages postés mardi 28 juin 2011Date d'inscription 21 juillet 2017 Dernière intervention - 10 juil. 2017 à 11:55
La fonction SI peut prendre plus de 3 arguments ?
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci bien Via55 et Daniel Co
Sur cette dernière proposition, il a fallu que je mette de ; entre les voyelles pour qu'Excel accepte la formule.
Cependant rien ne se produit (ce qui est déjà un progrès !).
La formule est certainement proche mais je n'ai pas encore le résultat souhaité.
Merci
PS / dans mon tableau d'essais la formule est acceptée alors que ds mon vrai tableau la formule apparait malgré les divers manips ?!
Donnez votre avis
Utile
+0
plus moins
Re,

Chez moi elle fonctionne bien, voilà le fichier :
https://mon-partage.fr/f/m5kKubJM/

Cdlmnt
Via
Donnez votre avis
Utile
+0
plus moins
Aaaaaaaah, c'est beau le génie. Bravo, bravo : très fort.
C'est simple..., sauf qu'il fallait le trouver ! Cela marche pile poil.
Encore merci bien
Donnez votre avis
Utile
+0
plus moins
Bien !
Je passe le sujet en résolu
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !