Formule Excel comparaison de dates [Résolu]

francanava 5 Messages postés mercredi 5 juillet 2017Date d'inscription 18 octobre 2017 Dernière intervention - 5 juil. 2017 à 12:01 - Dernière réponse : francanava 5 Messages postés mercredi 5 juillet 2017Date d'inscription 18 octobre 2017 Dernière intervention
- 7 juil. 2017 à 09:50
Je voudrais faire une formule qui teste des dates avec Des SI imbriqués pour obtenir le résultat suivant
Test de date naissance
Si ne avant 1917 Senior
Si ne entre 01/01/1938 et 01/91/1917. Vétéran 2
SI ne être 01/01/1958 et 01/0/1938. Vétéran 1
SI ne apres 01/01/1958 Junior


Bien que connaissant bien Excel je n'y arrive pas car j'ai du mal à comprendre. Si je dois mettre la date en format 01/01/aaaa ou aaaa/01/01 et surtout dans quel sens faire le test 01/01/2000 est il < ou > à 01/91/2010 par exemple
Afficher la suite 

8 réponses

Répondre au sujet
ccm81 8247 Messages postés lundi 18 octobre 2010Date d'inscription 13 février 2018 Dernière intervention - 5 juil. 2017 à 12:18
0
Utile
Bonjour

Essaies ceci avec ta date en A2
=SI(A2<DATE(1917;1;1);"senior";SI(A2<DATE(1938;1;1);"veteran 2";SI(A2<DATE(1958;1;1);"veteran1";"junior")))

Cdlmnt
Commenter la réponse de ccm81
PHILOU10120 4844 Messages postés lundi 16 avril 2012Date d'inscription 14 février 2018 Dernière intervention - Modifié par PHILOU10120 le 5/07/2017 à 12:21
0
Utile
Supprimé CCM1 a été plus rapide

C'est en forgeant que l'on devient forgeron. -   C'est au pied du mur que l'on voit le maçon - on apprend toujours de ses erreurs
Commenter la réponse de PHILOU10120
francanava 5 Messages postés mercredi 5 juillet 2017Date d'inscription 18 octobre 2017 Dernière intervention - 6 juil. 2017 à 00:37
0
Utile
1
voila la formule que j'ai rentrée ..mais elle ne marche pas
=SI(G3="";"?";(SI(G2<DATE(1917;1;1);"senior";SI(G2<DATE(1938;1;1);"veteran 2";SI(G2<DATE(1958;1;1);"veteran1";"junior")))))

voici le résultat obtenu qui est faux :
Date de Naissance Catégorie
20/12/1911 junior
01/10/1949 senior
13/11/1950 veteran1
21/05/1967 veteran1
07/06/1954 junior
04/05/1932 veteran1
24/03/1939 veteran 2

est ce parce que la date est en format jj/mm/aaaa et non aaaa/mm/jjj
si oui comment la transposer avant d'appliquer ma formule ?
j'y perd mon latin et ...ça m'énerve !!!!!!
merci de votre aide
Voici la formule de ccm81, ajustée selon tes nouvelles indications :
=SI(G3="";"?";SI(G3<DATE(1917;1;1);"Senior";SI(G3<DATE(1938;1;1);
"Vétéran 2";SI(G3<DATE(1958;1;1);"Vétéran 1";"Junior"))))
Commenter la réponse de francanava
ccm81 8247 Messages postés lundi 18 octobre 2010Date d'inscription 13 février 2018 Dernière intervention - 6 juil. 2017 à 13:02
0
Utile
bonjour

est ce parce que la date est en format jj/mm/aaaa et non aaaa/mm/jjj

non, le format n'a pas d'influence sur la récupération d'une donnée de type date, il ne concerne que l'affichage de la date.
Une date est un nombre entier qui va de 1 pour le 1° janvier 1900 à 42922 pour aujourdhui.
Peux tu envoyer un bout de ton fichier
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
Commenter la réponse de ccm81
medjoy 146 Messages postés vendredi 24 juillet 2009Date d'inscription 6 juillet 2017 Dernière intervention - 6 juil. 2017 à 15:46
0
Utile
Bonjour, il faut déjà savoir qu'une date correspond à un nombre dans Excel. Par exemple, si vous saisissez 01/01/2000 dans une cellule puis que vous changer le format en "Standard", la cellule va afficher 30526.
A partir de là votre formule est simple à mettre en place. Je vous donne l'exemple pour la première condition :
=SI(A2<6211;ACTION SI VRAI; ACTION SI FAUX) (ici 6211 correspond à la date 01/01/1917)
Commenter la réponse de medjoy
0
Utile
Bonjour francanava,

Fichier Excel 2007 : https://mon-partage.fr/f/FPZ5oiM7/

Si ton problème est réglé : n'oublie pas de remercier ccm81 car c'est
sa formule que j'ai adaptée à tes besoins ; merci d'aller en haut de
page pour cliquer sur le lien « Marquer comme résolu ».
 
Commenter la réponse de fred
francanava 5 Messages postés mercredi 5 juillet 2017Date d'inscription 18 octobre 2017 Dernière intervention - 7 juil. 2017 à 09:50
0
Utile
merci a vous tous de votre aide

il devait y avoir une subtilité que je ne voyais pas
bref ça marche !!!!et je protège pour ne pas perdre cette foutue formule !!
encore merci
Commenter la réponse de francanava