Signaler

Formule Excel comparaison de dates [Résolu]

Posez votre question francanava 5Messages postés mercredi 5 juillet 2017Date d'inscription 18 octobre 2017 Dernière intervention - Dernière réponse le 7 juil. 2017 à 09:50 par francanava
Je voudrais faire une formule qui teste des dates avec Des SI imbriqués pour obtenir le résultat suivant
Test de date naissance
Si ne avant 1917 Senior
Si ne entre 01/01/1938 et 01/91/1917. Vétéran 2
SI ne être 01/01/1958 et 01/0/1938. Vétéran 1
SI ne apres 01/01/1958 Junior


Bien que connaissant bien Excel je n'y arrive pas car j'ai du mal à comprendre. Si je dois mettre la date en format 01/01/aaaa ou aaaa/01/01 et surtout dans quel sens faire le test 01/01/2000 est il < ou > à 01/91/2010 par exemple
Utile
+0
plus moins
Bonjour

Essaies ceci avec ta date en A2
=SI(A2<DATE(1917;1;1);"senior";SI(A2<DATE(1938;1;1);"veteran 2";SI(A2<DATE(1958;1;1);"veteran1";"junior")))

Cdlmnt
Donnez votre avis
Utile
+0
plus moins
Supprimé CCM1 a été plus rapide

Donnez votre avis
Utile
+0
plus moins
voila la formule que j'ai rentrée ..mais elle ne marche pas
=SI(G3="";"?";(SI(G2<DATE(1917;1;1);"senior";SI(G2<DATE(1938;1;1);"veteran 2";SI(G2<DATE(1958;1;1);"veteran1";"junior")))))

voici le résultat obtenu qui est faux :
Date de Naissance Catégorie
20/12/1911 junior
01/10/1949 senior
13/11/1950 veteran1
21/05/1967 veteran1
07/06/1954 junior
04/05/1932 veteran1
24/03/1939 veteran 2

est ce parce que la date est en format jj/mm/aaaa et non aaaa/mm/jjj
si oui comment la transposer avant d'appliquer ma formule ?
j'y perd mon latin et ...ça m'énerve !!!!!!
merci de votre aide
fred- 6 juil. 2017 à 03:54
Voici la formule de ccm81, ajustée selon tes nouvelles indications :
=SI(G3="";"?";SI(G3<DATE(1917;1;1);"Senior";SI(G3<DATE(1938;1;1);
"Vétéran 2";SI(G3<DATE(1958;1;1);"Vétéran 1";"Junior"))))
Répondre
Donnez votre avis
Utile
+0
plus moins
bonjour

est ce parce que la date est en format jj/mm/aaaa et non aaaa/mm/jjj

non, le format n'a pas d'influence sur la récupération d'une donnée de type date, il ne concerne que l'affichage de la date.
Une date est un nombre entier qui va de 1 pour le 1° janvier 1900 à 42922 pour aujourdhui.
Peux tu envoyer un bout de ton fichier
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
Donnez votre avis
Utile
+0
plus moins
Bonjour, il faut déjà savoir qu'une date correspond à un nombre dans Excel. Par exemple, si vous saisissez 01/01/2000 dans une cellule puis que vous changer le format en "Standard", la cellule va afficher 30526.
A partir de là votre formule est simple à mettre en place. Je vous donne l'exemple pour la première condition :
=SI(A2<6211;ACTION SI VRAI; ACTION SI FAUX) (ici 6211 correspond à la date 01/01/1917)
Donnez votre avis
Utile
+0
plus moins
Bonjour francanava,

Fichier Excel 2007 : https://mon-partage.fr/f/FPZ5oiM7/

Si ton problème est réglé : n'oublie pas de remercier ccm81 car c'est
sa formule que j'ai adaptée à tes besoins ; merci d'aller en haut de
page pour cliquer sur le lien « Marquer comme résolu ».
 
Donnez votre avis
Utile
+0
plus moins
merci a vous tous de votre aide

il devait y avoir une subtilité que je ne voyais pas
bref ça marche !!!!et je protège pour ne pas perdre cette foutue formule !!
encore merci
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !