Signaler

Probleme clavier sans fil debian [Résolu]

Posez votre question djedelta - Dernière réponse le 11 juil. 2017 à 09:44 par mamiemando
Bonjour,

j ai installé debian 8 sur un pc le probleme est le suivant : j ai un clavier sur le port ps/2 qui est en azerty, je viens d installer un clavier sans fil usb reconnu en qwerty et donc obligé de taper la commande setxkbmap fr a chaque redem, comment pourrais je regler ce probleme.

Merci
Utile
+0
plus moins
Bonjour,

Pour la partie console :
https://wiki.debian.org/fr/Keyboard

Pour le mode graphique, il suffit de changer la disposition directement dans ton environnement graphique et il devrait s'en souvenir d'une fois sur l'autre. Dis nous ce que tu utilises (gnome, kde...) si tu as besoin de plus de précisions.

Bonne chance
Donnez votre avis
Utile
+0
plus moins
Bonjour Mamiemando,

merci d'avoir répondu, concernant l’environnement, j'utilise LXDE et je ne vois pas d'options concernant le paramétrage de mon clavier usb sans fil.

Merci
jns55- 30 juin 2017 à 15:42
Bonjour,
Tu as aussi la possibilité de lancer la commande automatiquement setxkbmap fr au démarrage de lxde (mettre la commande dans l'autostart)

Mais il y a une chose qui m'échappe : si ton clavier ps2 est paramétré sur azerty, normalement, quel que soit le clavier que tu connectes, il devrait aussi être paramétré en azerty puisque cette disposition est définie dans le paramétrage de X11. (voir le fichier /etc/X11/xorg.conf si tu en as un)

Pour lxde, il existe un greffon qui permet de changer la disposition du clavier
https://wiki.lxde.org/fr/Changer_de_disposition_de_clavier
Répondre
djedelta- 30 juin 2017 à 16:02
Bonjouir jns55,

merci pour votre réponse claire et rapide, je n'ai pas de fichier xorg.conf mais un dossier xorg.conf.d avec plusieurs fichiers dedans.
Étrange en effet que ce clavier usb sans fil Logitech soit en qwerty alors que l'autre soit en azerty, surement parce que a l'install de débian il n'y avait que le clavier ps2.
Je vais tester avec l'autostart et je vous dis ca

Merci
Répondre
Donnez votre avis
Utile
+0
plus moins
Re bonjour jns55,

impeccable pour l'autostart par contre le clavier est toujours en qwerty a la fenetre de login, une idée?
jns55- 30 juin 2017 à 16:42
Va voir dans le fichier /etc/default/keyboard.
Pour en savoir plus :
https://wiki.debian.org/fr/Keyboard
Répondre
Donnez votre avis
Utile
+0
plus moins
Voici le contenu du fichier :
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=

BACKSPACE="guess"

Le KXBOPTIONS est vide, peut etre mettre "fr" dedans?
jns55- 30 juin 2017 à 16:56
Non, c'est correct.
Répondre
Donnez votre avis
Utile
+0
plus moins
Donc étrange qu'au login il soit en qwerty et en azerty quand jarrive sur le bureau en tout cas merci pour votre aide ;)
jns55- 30 juin 2017 à 17:06
Tu es en azerty lorsque tu arrives sur le bureau parce que tu as fait exécuter la commande setxkbmap fr dans l'autostart. Ce qu'il faut c'est passer le clavier en azerty avant la session X pour que ton login ait le bon clavier.
J'ai eu ce problème sous Debian Pixel mais je n'arrive plus à retrouver quel fichier j'ai modifié pour arranger ça. Une chose est certaine c'est tout bête, un fr à placer mais dans quel fichier ? ? ?
Répondre
Donnez votre avis
Utile
+0
plus moins
Merci jns55 !!! pour l'astuce de l'autostart, toujours en qwerty lors du login mais ce n'est pas un problème.

Bonne continuation
mamiemando 27955Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 25 septembre 2017 Dernière intervention - 11 juil. 2017 à 09:44
Si pour le login tu parles du gestionnaire de connexion (ssdm, lightdm...) il faut paramétrer le clavier dans ton panneau de configuration.
https://doc.ubuntu-fr.org/lightdm#changer_l_agencement_du_clavier
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !