Signaler

Formule OU [Résolu]

Posez votre question pat - Dernière réponse le 21 juin 2017 à 07:57 par Vaucluse
Bonjour,

J''ai une formule qui fonctionne aprfaitement, cependant j'aimerais ajouter une fonction " OU ".
Voici la formule de base :
=SI(LIGNES(Feuil1!$1:1)>NB.SI(Feuil1!D$1:D$30;S$1);"";INDEX(Feuil1!A$1:A$30;EQUIV(S$1;Feuil1!D$1:D$30;0)+LIGNES(Feuil1!$1:1)-1))

Je souhaiterais donc pouvoir placer le "OU" sur les parties en gras
donc OU S1 ; S2 ; S3 ; S4 ; S5

Merci d'avance pour votre aide


Afficher la suite 
Utile
+0
plus moins
Bonjour
votre formule demande quelques explications
par exemple
1°) quel est le but de LIGNES($1:1) qui renvoie 1 sur la 1°; ligne de la formule?
2°) que se passe t il si D1:D30 contiennent plusieurs code inscrit en S1:S5, sachant que EQUIV ne renverra jamais que le 1° trouvé?
..bref, quel sont vos arguments à mettre en place
à vous lire
crdlmnt

Donnez votre avis
Utile
+0
plus moins
Il est peut être possible de faire plus simple, cependant le but de la formule est simplement de véririer si :
sur la feuille1 en colone D si la valeur texte correspond a soit feuille2 S1 ou S2 ou S3 ou S4 ou S5 si c'est le cas, copier coller La valeur inscrite en colone A qui se trouve sur la même ligne.

Pouvoir étirer cette formule vers le bas
il est bien sur possible qu'il y aie plusieurs fois des valeur identique en colonne D

Si mes informations ne sont pas suffisament clair n'hésitez pas a me le faire savoir

Encore merci
Vaucluse 19764Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 21 juin 2017 Dernière intervention - 20 juin 2017 à 11:14
Alors je vous propose cette formule à adapter pour:
  • des références en S1:S5
  • à chercher dans le champ D1:D30
  • pour ressortir la valeur correspondante en A1:A30

=SIERREUR(INDEX($A$1:$A$30;PETITE.VALEUR(SI(NB.SI($S$1:$S$5;$D$1:$D$30);LIGNE($A$1:$A$30));LIGNE(A1)));"")

attention. Cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle s'affiche automatiquement entre accolades dans la barre des tâches.
Ca donne ça pour info
http://www.cjoint.com/c/GFujn2TN4NC

crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Serieusement j'ai du mal a comprendre cette formule mais elle fonctionne parfaitement alors il me reste simplement a dire un grand merci!!!!

Merci
Vaucluse 19764Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 21 juin 2017 Dernière intervention - 21 juin 2017 à 07:57
C''est l'essentiel
je passe le sujet en résolu
bonne route
crdlmnt
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !