Signaler

VBA [Résolu]

Posez votre question tanoussou 4Messages postés vendredi 10 juin 2016Date d'inscription 20 juin 2017 Dernière intervention - Dernière réponse le 20 juin 2017 à 01:09 par tanoussou
Au secoure!!
Salut à tous les membres de la communauté.
Je suis un débutant en matière de réalisation des macros. Actuellement je suis entrain de réaliser un travail sur excel, voilà que j'ai besoin d'une macro afin d'automatiser mon travail.
Voici mon problème:
J'ai un tableau de deux colonnes A et B avec chacune 5 lignes et je souhaiterais lorsque la valeur de A1 est > 95%, donc qu'il soit écrit dans B1 "Bon" ou si A1 est >=85 ou <95% donc qu'il soit écrit dans B1 "Satisfaisant" ou si A1 est >=70% ou <85%, donc qu'il soit écrit dans B1 "A améliorer".

J'ai besoin de votre aide, merci à toutes et à tous.
Afficher la suite 
Utile
+0
plus moins
Bonjour tanoussou,

Formule en B1 (sur une seule ligne, à tirer vers le bas) :

=SI(A1>=95%;"Bon";SI(A1>=85%;"Satisfaisant";
SI(A1>=70%;"A améliorer";"")))

⚠  Dans ton énoncé, tu as >95% puis <95% ; donc pour 95%
exactement, est-ce "Bon" ou "Satisfaisant" ? sans indication,
j'ai choisi "Bon" ; d'où le 1er « >= » (et pas « > »).

NB : Si c'est <70% : aucun texte : "" ; mais tu peux le remplacer
par le texte de ton choix, par exemple : "Révisions nécessaires".
 
tanoussou 4Messages postés vendredi 10 juin 2016Date d'inscription 20 juin 2017 Dernière intervention - 20 juin 2017 à 01:09
Bonjour Steve, merci beaucoup pour ta réponse, c'est un bon kdo pour mon anniversaire qui est le 20 juin :) ... Mon problème est résolu. J'ai pu ajouter d'autres conditions en plus. Je ne savais pas qu'on peut le faire sans les macros.
Encore merci Steve.
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !